Aller au contenu
Ubuntu31

Plusieurs problèmes pour l'utilisation d'Ubuntu 18.04

Messages recommandés

Bonjour à tous,

Il y a quelques jours, j'ai suivi le tutoriel du site pour installer un dual boot Windows 10/Ubuntu 18.04 (au passage, le tuto est excellent !). Cependant, j'ai pas mal de petits soucis. J'ai cherché pas mal d'informations sur internet, j'ai pu en résoudre certains, mais étant peu habitué à Linux, d'autres n'ont pas pu être résolus. Je me tourne donc vers la communauté pour demander de l'aide sur les points suivants :

  • Le premier tourne autour de l'option acpi=off (à rajouter dans les configurations de GRUB). A quoi sert-elle exactement ?
    • Sans cette option :
      • Ubuntu ne démarre pas (il se fige sur l'écran violet au moment du login), et je suis obligé de passer par le mode recovery, puis de reprendre le démarrage normal (dans ce cas-là, ça fonctionne, je ne comprends pas du tout) ;
      • Les animations dans Ubuntu (agrandissement/réduction de fenêtre par exemple) sont comme "désactivées" (dans les paramètres, dans les "Tweaks", les animations sont activées mais en réalité tout se passe instantanément sans animation) ;
      • Impossible de régler la luminosité de l'écran (que ce soit par la barre du haut, les réglages ou via le clavier).
    • Si j'active l'option acpi=off :
      • Ubuntu démarre bien sans passer par le mode recovery ;
      • Les animations sont font normalement ;
      • La luminosité est réglable (l'option apparaît dans Ubuntu) ;
      • En revanche, je n'ai plus de contrôle sur ma batterie : l'icône de batterie n'apparaît pas dans la barre du haut, aucune information n'est donnée dans les réglages, et les commandes que j'ai pu tester (upower notamment) semblent indiquer que la batterie n'est pas reconnue.
  • Le deuxième problème concerne le mode veille, plus particulièrement la sortie de veille : l'ordinateur semble se mettre correctement en veille, mais dès que je le rallume, j'ai un écran noir (vraiment noir, il ne semble même pas rétro-éclairé) et je ne peux rien faire. Je peux le remettre en veille en appuyant sur le bouton d'alimentation, ou l'éteindre complètement en appuyant plus longuement.
  • Dernière chose, je ne peux pas brancher de deuxième écran. J'ai une sortie HDMI, dans laquelle je branche un adapteur HDMI > VGA pour aller vers un écran avec entrée VGA. Lorsque j'utilise la commande xrandr, j'ai ce message d'erreur : 
    xrandr: Failed to get size of gamma for output default
    Screen 0: minimum 1920 x 1080, current 1920 x 1080, maximum 1920 x 1080
    default connected primary 1920x1080+0+0 0mm x 0mm
       1920x1080     77.00*
    Est-ce que cela peut venir d'un driver manquant ?

 

Je suis désolé de poser autant de questions, mais c'est vraiment embêtant pour utiliser confortablement mon nouvel OS ! Merci d'avance à ceux qui prendront du temps pour m'aider :rolleyes:

Partager ce message


Lien à poster

Je me permets de remonter le sujet... Personne n'a d'idée ?

J'ai essayé toutes les options suivantes, mais aucune ne donne de résultat...

Citation
nolapic
noapic
acpi_osi=“Linux”
acpi_osi=“Windows 2006”
acpi=ht
pci=noacpi
acpi=noirq
pnpacpi=off

Je commence à désespérer :unsure:

Partager ce message


Lien à poster

Bonjour @Ubuntu31 (Toulouse ? :biggrin:

Je vais faire un petit appel à @rodriguem7973 ou éventuellement à @Le Crabe notre chef à tous (c'est l'admin vénéré du forum :wink:) qui utilisent linux tous les deux , perso j'ai testé sur virtual box mais comme linux est très peu riche en jeux je n'ai pas persévéré ni installé (mea culpa etc) 

Partager ce message


Lien à poster

salut ubuntu31

pourquoi tu as mi 77 ?.  mais 60  

tapez

cvt 1920 1080 60

répondre quoi

 

Partager ce message


Lien à poster

De Toulouse même en effet :biggrin:

Merci à tous les deux pour vos réponses. Concernant la réponse de @rodriguem7973, voici le résultat que j'obtiens quand je tape cette commande :

Citation

root@pierre-laptop:/home/root# cvt 1920 1080 60
# 1920x1080 59.96 Hz (CVT 2.07M9) hsync: 67.16 kHz; pclk: 173.00 MHz
Modeline "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync


root@pierre-laptop:/home/root# xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1920 x 1080, current 1920 x 1080, maximum 1920 x 1080
default connected primary 1920x1080+0+0 0mm x 0mm
   1920x1080     77.00*

 

Partager ce message


Lien à poster
Posté(e) (modifié)

Yep,

Au lieu de mettre acpi=off, essaie plutôt ça acpi_osi=! acpi_osi=\"Windows 2009\

Rappel : Ajoute un paramètre au boot

sudo nano /etc/default/grub

Ajoute acpi_osi=! acpi_osi=\"Windows 2009\" comme ci dessous :

GRUB_CMDLINE_LINUX_DEFAULT ="quiet [...] nouveau.modeset=0 acpi_osi=! acpi_osi=\"Windows 2009\""

Mets ensuite à jour GRUB pour qu'il prenne en compte cette modification :

sudo update-grub

Redémarre ton PC.

Modifié par Mreve
  • Plusser (+1) 4

Partager ce message


Lien à poster

Salut,

Wahou, cela corrige quasiment tous mes problèmes ! Un immense merci ! C'est possible d'avoir quelques explications ? :smile:

Le seul soucis qui me reste concerne l'utilisation d'un second écran. J'ai l'impression que celui-ci n'est pas détecté... J'ai installé ARandR, et dans le menu "Ecrans", j'ai eDP1 qui est paramétrable, mais aussi HDMI1 et VIRTUAL1 qui, eux, sont grisés.

Partager ce message


Lien à poster
Posté(e) (modifié)

salut !

tu tapes :

Citation

xrandr --newmode "1920x1080_60.00"  148.50  1920 2008 2052 2200  1080 1084 1089 1125 +hsync +vsync

xrandr --output HDMI --mode 1920x1080_70.00

ou

xrandr --addmode

si tu ne trouvé pas alors une aide ubunu-fr wiki

https://doc.ubuntu-fr.org/xrandr

 

tu as quoi comme la carte graphique ?

Modifié par rodriguem7973

Partager ce message


Lien à poster

Salut,

Ajouter ce mode n'a pas fonctionné pour ma part. Je n'ai pas trouvé (ou pas sur trouver) mon bonheur dans la doc que j'ai déjà passée plusieurs fois...

Pour ma carte graphique :

lspci -vnn | grep -A 12 '\''[030[02]\]' | grep -Ei "vga|3d|display|kernel"

00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:591b] (rev 04) (prog-if 00 [VGA controller])
01:00.0 3D controller [0302]: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] [10de:1c8d] (rev a1)

A noter que quand je tape la commande xrandr, voici les résultats que j'obtiens :

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 380mm x 210mm
   1920x1080     60.02*+  59.93    40.02  
   1680x1050     59.88  
   1600x1024     60.17  
   1400x1050     59.98  
   1600x900      60.00    59.95    59.82  
   1280x1024     60.02  
   1440x900      59.89  
   1400x900      59.96    59.88  
   1280x960      60.00  
   1368x768      60.00    59.88    59.85  
   1360x768      59.80    59.96  
   1280x800      59.81    59.91  
   1152x864      60.00  
   1280x720      59.86    60.00    59.74  
   1024x768      60.00  
   1024x576      60.00    59.90    59.82  
   960x540       60.00    59.63    59.82  
   800x600       60.32    56.25  
   864x486       60.00    59.92    59.57  
   640x480       59.94  
   720x405       59.51    60.00    58.99  
   640x360       59.84    59.32    60.00  
HDMI1 disconnected 1920x1080+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1920x1080_60.00  60.00* 
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

 

Partager ce message


Lien à poster

salut !

comment installé un driver nvidia en ubuntu :)

Citation

sudo add-apt-repository ppa:graphics-drivers/ppa 
sudo apt update 
ubuntu-drivers devices  
sudo apt install nvidia-(numéro du pilote)

 

  • Plusser (+1) 1

Partager ce message


Lien à poster

Salut !

J'avance doucement... Mais c'est toujours pas ça !

J'ai suivi ces consignes pour installer le driver nvidia-driver-430, qui était recommandé dans la liste des drivers donnés par la commande ubuntu-drivers devices. L'installation a fonctionné mais rien n'a changé pour mon problème.

J'ai essayé la commande nvidia-settings, voici ce que j'obtiens :

root@pierre-laptop:~# nvidia-settings

ERROR: NVIDIA driver is not loaded


ERROR: Unable to load info from any available system


(nvidia-settings:30887): GLib-GObject-CRITICAL **: 12:59:23.700: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
** Message: 12:59:23.702: PRIME: Requires offloading
** Message: 12:59:23.702: PRIME: is it supported? yes

J'ai aussi essayé de générer le fichier de configuration, avec une erreur :

root@pierre-laptop:~# nvidia-xconfig 

WARNING: Unable to locate/open X configuration file.

Package xorg-server was not found in the pkg-config search path.
Perhaps you should add the directory containing `xorg-server.pc'
to the PKG_CONFIG_PATH environment variable
No package 'xorg-server' found
New X configuration file written to '/etc/X11/xorg.conf'

 

Partager ce message


Lien à poster

Bonjour,

Je reviens vers vous car j'ai eu de "gros" soucis :blush:

J'ai tenté beaucoup de manips pour installer le driver manquant pour utiliser deux écrans. Tellement de manips... que j'ai plus ou moins bousillé mon Ubuntu et que j'ai préféré le réinstaller. J'ai donc maintenant un OS clean sur lequel je n'ai fait aucune modification pour ça. Voici le résultat de quelques commandes :

root@pierre-laptop:~# xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 382mm x 215mm
   1920x1080     60.02*+  60.01    59.97    59.96    59.93    40.02  
   1680x1050     59.95    59.88  
   1600x1024     60.17  
   1400x1050     59.98  
   1600x900      59.99    59.94    59.95    59.82  
   1280x1024     60.02  
   1440x900      59.89  
   1400x900      59.96    59.88  
   1280x960      60.00  
   1440x810      60.00    59.97  
   1368x768      59.88    59.85  
   1360x768      59.80    59.96  
   1280x800      59.99    59.97    59.81    59.91  
   1152x864      60.00  
   1280x720      60.00    59.99    59.86    59.74  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   1024x576      59.95    59.96    59.90    59.82  
   960x600       59.93    60.00  
   960x540       59.96    59.99    59.63    59.82  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   864x486       59.92    59.57  
   800x512       60.17  
   700x525       59.98  
   800x450       59.95    59.82  
   640x512       60.02  
   720x450       59.89  
   700x450       59.96    59.88  
   640x480       60.00    59.94  
   720x405       59.51    58.99  
   684x384       59.88    59.85  
   680x384       59.80    59.96  
   640x400       59.88    59.98  
   576x432       60.06  
   640x360       59.86    59.83    59.84    59.32  
   512x384       60.00  
   512x288       60.00    59.92  
   480x270       59.63    59.82  
   400x300       60.32    56.34  
   432x243       59.92    59.57  
   320x240       60.05  
   360x202       59.51    59.13  
   320x180       59.84    59.32  
HDMI-1 disconnected (normal left inverted right x axis y axis)


root@pierre-laptop:~# ubuntu-drivers devices
== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
modalias : pci:v000010DEd00001C8Dsv0000103Csd00008219bc03sc02i00
vendor   : NVIDIA Corporation
model    : GP107M [GeForce GTX 1050 Mobile]
driver   : nvidia-driver-390 - distro non-free recommended
driver   : xserver-xorg-video-nouveau - distro free builtin


root@pierre-laptop:~# lspci -vnn | grep -A 12 '\''[030[02]\]' | grep -Ei "vga|3d|display|kernel"
00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:591b] (rev 04) (prog-if 00 [VGA controller])
01:00.0 3D controller [0302]: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] [10de:1c8d] (rev a1)

Du coup, est-ce que quelqu'un pourrait m'aider pour que j'évite de refaire des bêtises ?

Merci beaucoup !

Modifié par Ubuntu31

Partager ce message


Lien à poster

essaie

xandr -s 1920x1080_60 ?

 

 

Modifié par rodriguem7973

Partager ce message


Lien à poster

Bonjour,

Cela ne change rien du tout... (mais je n'ai pas d'erreur dans la commande).

Partager ce message


Lien à poster

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Restaurer la mise en forme

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


×
×
  • Créer...