Aller au contenu
FrancoisC

Accès extérieur et redirection de ports Archer C7 + E3372

Messages recommandés

Bonsoir,

J'ai suivi le tuto de @Le Crabe pour créer ma box 4G. Elle fonctionne parfaitement et j'atteins 70 Mb/s en téléchargement. J'ai installé un firmaware Openwrt sur l'Archer C7.

Cependant je souhaite accéder à des caméras ip depuis l'extérieur.

J'ai donc :

  • Ajouté en ip DMZ l'adresse 192.168.8.100 sur le routeur E3372 Hi-Link
  • Créé des baux statiques pour mes caméras avec leur adresse MAC sur le réseau du routeur TP-Link Archer C7
  • Créé des règles NAT pour rediriger les flux entrants par des ports définis sur les ports de caméras sur le routeur Archer C7
  • Pour l'instant j'utilise l'adresse IP extérieure donnée par ma clé (consulté avec whatsmyip). Mais j'ai prévu d'ajouter un DDNS No-IP ensuite.

Je ne parviens cependant toujours pas à  accéder aux caméras. Ai-je oublié une manipulation.

Merci pour votre aide.

..

 

Partager ce message


Lien à poster

Salut @FrancoisC,

Est-ce que déjà tu arrives à accéder à ton routeur depuis l'extérieur ?

Il faut éditer le fichier /etc/config/firewall et y écrire (remplace le port 443 par 80 si tu n'utilises pas le HTTPS sur LuCI) :

config 'redirect'
 option 'name' 'luci-remote'
 option 'src' 'wan'
 option 'proto' 'tcp'
 option 'src_dport' '9999'
 option 'dest_port' '443'
 option 'target' 'DNAT'
 option 'dest' 'lan'

Dès lors tu peux accéder à LuCI depuis l'extérieur via l'URL : https://adresse_ip_de_ton_router:9999

Source : https://aiotutorials.wordpress.com/2016/06/28/openwrt-remote-access/

Tu peux peut-être t'inspirer de cette config et l'adapter pour tes caméras ? Il faudrait pointer vers l'adresse IP locale de ta caméra.

Partager ce message


Lien à poster

Merci @LeCrabe

Je vais essayer avec une autre clé 4G, ma première étant bloquée depuis une mise à jour. 

En revanche il n'y a pas d'autre manipulation à faire sur le routeur de la clé en dehors de la DMZ et de désactiver le firewall ?

Partager ce message


Lien à poster

Malheureusement cela ne fonctionne pas.

Pire j’ai désactivé la fonctionnalité DHCP de ma deuxième clé E3372 pour voir si cela améliorait les choses. 

Désormais je ne parviens plus à communiquer avec la clé 4G et DC Unlocker ne la détecte pas...

Partager ce message


Lien à poster

Problème résolu (pour le DHCP off) en fixant l'adresse IPV4 à 192.168.8.100 et le gateway à 192.168.8.1.

  • J'aime 1

Partager ce message


Lien à poster
Le 07/06/2019 à 15:26, Le Crabe a dit :

Salut @FrancoisC,

Est-ce que déjà tu arrives à accéder à ton routeur depuis l'extérieur ?

Il faut éditer le fichier /etc/config/firewall et y écrire (remplace le port 443 par 80 si tu n'utilises pas le HTTPS sur LuCI) :


config 'redirect'
 option 'name' 'luci-remote'
 option 'src' 'wan'
 option 'proto' 'tcp'
 option 'src_dport' '9999'
 option 'dest_port' '443'
 option 'target' 'DNAT'
 option 'dest' 'lan'

Dès lors tu peux accéder à LuCI depuis l'extérieur via l'URL : https://adresse_ip_de_ton_router:9999

Source : https://aiotutorials.wordpress.com/2016/06/28/openwrt-remote-access/

Tu peux peut-être t'inspirer de cette config et l'adapter pour tes caméras ? Il faudrait pointer vers l'adresse IP locale de ta caméra.

Bon je crois que ce n'est pas possible de rediriger des ports à partir d'une clé 4G. Les connexions mobiles ne semblent pas permettre pour les abonnements grand public de rediriger des ports.

J'ai bien réussi à lier ma connexion à service d'ip fixe (No-ip) mais même le ping de mon adresse ip publique ne fonctionne pas.

Apparemment la seule solution serait de souscrire à un service VPN payant pour créer un tunnel vers une IP publique qui autorise la redirection des ports. Bref cela sera compliqué. Je vais tout de même tester si les caméras P2P fonctionnent avec ce routeur + clé 4G.

  • J'aime 1

Partager ce message


Lien à poster

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


×
×
  • Créer...