Aller au contenu
tiger13

soucis de bios &switch graphique sur pc portable

Messages recommandés

Posté(e) (modifié)

bien le bonjour tout le monde !

voilà, je rencontre un gros soucis sur mon pc portable qui date un peu (un HP DV6 3140sf) actuellement sous w7.

MON BUT : changer D'OS suite à arret prochain de W7 ....ET SURTOUT ! avoir la cg secondaire "discrete" qui marche ! (la petite "integré" je m'en foue ,à la limite....de toure façon la batterie ne tient plus.)

le systeme graphique en question : AMD m880g with ati radeon mobility hd 4250 + ati hd 5470

Sur W7 et le site hp il n'y a qu'un "tres" vieux driver permettant de switcher (avec ati powerplay dans le panneau catalyst)

j'ai essayé avec W10 et ça ne marche pas ...drivers de base incomplet uniquement pour hd "4200 series" car pas supporté   ,pas de switch ,,les pilotes proprio plantent ,refus de w10 d'installer ces drivers ........bref ! la cata !!! en plus d'un OS qui fait super chauffer le pc ,dingue...

j'ai testé avec Linux Mint  cinnamon (je crois bien qu'il va rester sur ça au final !) mais switcheroo ne marche pas ! pour l'intant "choux-blanc" ...

sur le site "bios-mods" ,j'ai trouvé un bios debloqué (vu que des manips que j'ai sur le net pour faire apparaître ce "advanced" ne marchent pas)  et ne suis guère avançé .

le bios : insydeh20 rev 3.5 version f29  (mais pas d'option claire pour une desactivation de l'integré principale hd4250 ,ce qui m'aurait arrangé !  )

les options dispos dans "conf de video" sont

-discrete gfx Modules none ,m92(c'est la hd 4250) ,madison (la hd 5470) et quoi que je mette ,cela,ne semble rien faire .

j'ai rien compris à ça !!!pas trouvé d'infos ===>>>>

lanes 0-3 ( choix : desactivée ,port A ,port B ,DDI 1 ,DDI 2 ) les ddi ont un sous-choix display machin ,vga,hdmi . 

lanes 4-7 (idem)

lanes 8-11 (idem)

lanes 12-15 (idem)

merci d'avance à ceux qui m'aideront dans ce super casse-tete ! dans ce "challenge" ! 

Modifié par tiger13

Partager ce message


Lien à poster

Salut !

Il y a 3 heures, tiger13 a dit :

j'ai essayé avec W10 et ça ne marche pas ...drivers de base incomplet uniquement pour hd "4200 series" car pas supporté   ,pas de switch ,,les pilotes proprio plantent ,refus de w10 d'installer ces drivers ........bref ! la cata !!! en plus d'un OS qui fait super chauffer le pc ,dingue...

As-tu essayé d'installer le pilote en mode de compatibilité pour Windows 7 ?

PS : C'est "switch" graphique ou "chipset" graphique, que tu voulais écrire ?

Partager ce message


Lien à poster

oui ,ça ne fait rien ....

Là j'ai un autre soucis imprevu (grave???) du coup ! 

ecran noir total au demarrage !!! j'entends les sons de demarrage de windows ,c'est tout...

selon ce que dit le web en instruction ,j'ai enlevé la pile CM pour un clearcmos ,j'ai mis le bios (en xxx.bin) sur une clé usb ....tout tenté...: rier ne se passe ... aie ! 

Partager ce message


Lien à poster

Je ne sais pas si c'est grave.
Sans vouloir être critique, je ne trouve pas ce que tu écris très clair. Je ne sais pas dans quel sens interpréter certaines infos que tu donnes et l'ensemble me semble confus. Essayes d'être plus précis et/ou d'expliquer certaines infos particulières.

il y a 18 minutes, tiger13 a dit :

j'ai mis le bios (en xxx.bin) sur une clé usb ....tout tenté...: rier ne se passe ... aie !

C'est-à-dire, concrètement, tu as fait quoi ?! :roi-burgonde:

Partager ce message


Lien à poster

mais c'est tres Clair , j'ai bien precisé que j'ai suivit des procédures qu'on trouve sur le net (dont je vais pas copier/coller les pavés de tutos ici ) c'est à dire pour un reset et restaurer un bios à l'etat d'origine ,des fois que ça vienne de là (une corruption)=>donc le coup de la pile à enlever + mettre un bios sur une clef Usb ....les trucs habituels quoi....je peux pas dire plus ...j'allume puis ecran noir ....:blink:

Un ecran noir comme ça alors que j'entends windows qui se lance bien (j'ai dis que j'entends le son ) , c'est apparement soit le bios (car il a été modifié) ,soit autres choses de grave ....

 

Partager ce message


Lien à poster
il y a 25 minutes, tiger13 a dit :

c'est à dire pour un reset et restaurer un bios à l'etat d'origine ,des fois que ça vienne de là (une corruption)=>donc le coup de la pile à enlever + mettre un bios sur une clef Usb ....les trucs habituels quoi....je peux pas dire plus ...j'allume puis ecran noir ....:blink:

Yop là,

le flash du bios c'est mal passé ou pas la bonne version du bios.

HP Notebook System BIOS Update (AMD Processors)
    F.26 Rev.
HP Notebook System BIOS Update (AMD Processors)
    F.29

Il y a 15 heures, tiger13 a dit :

le bios : insydeh20 rev 3.5 version f29  (mais pas d'option claire pour une desactivation de l'integré principale hd4250 ,ce qui m'aurait arrangé !  )

ici tu parle que tu as ou avait un F29

je te conseil si tu as rétrogradé de Bios est de le remettre..

 

Partager ce message


Lien à poster

@Delta c'etait la f29 ,et puis j'ai trouvé une f29 modifié....et là oui ! faudrait que je tente (ce que j'ai essayé) de remettre proprement la f29 officielle que j'ai pris sur le site HP . 

mais je suis un peu perdu fans les manips avec cet usb qui ne veut pas flasher .(le coup d'appuyer sur la touche windows+b (ou windows +v) . La clé clignote mais on dirait qu'il ne trouve pas et l'ecran reste noir .

j'ai lu des trucs différents ,mais faut creer une usb bootable alors ??? 

Partager ce message


Lien à poster

EDIT !!!!!! C'est bon !!! oufff....ecran revenu !!!

ce qu'il s'est passé et que j'ai fais

me suis dis "meeerde !!! si windows demarre et des loupiotes de partout ,le bios a forcement tout allumé correctement ,il est donc fonctionnel et intact ....y a forcement juste un parametre que j'ai touché et qu'il ne fallait pas !

Alors operation de derniere chance ! sur un autre PC ,j'ai regardé une capture "visuelle" du bios pour imaginer mentalement + mes souvenirs  ,et A L'AVEUGLE  j'ai demarré le portable et appuie sur f10 pour acceder au bios jusqu'au bip qui est  bon signe (donc acces à la fenetre de confirmation save&exit par yes ou no ) ,puis fleche droite pour no (faut rester dans le bios)....j'ai vu que f9 c'etait "load values defaut" ,j'appuie ...,j'ai fait "entrée" pour yes (valeur par defaut sur la fenetre de confirmation) ....puis f10 et "entrée" pour sauvegarder et sortir =====>>> ça reboote et je retrouve enfin mon ecran !

ce que je trouve carrement bizarre ,c'est le fait que SANS source d'alim (batterie&cordon retirés) le fait d'enlever la pile CM 10 minutes (pas de jumper sur ce pc portable) + appuie long sur le bouton de demarrage pour l'électricité résiduelle N'AIE RIEN FAIT !!! tout les parametres sont toujours là ,sauf la date et heure ! la pile sert à rien sur ce pc ,mdr !!! 

2eme choses : malgré les tutos (qu'on trouve meme chez HP)  ,impossible de flasher le bios par un fichier en .bin sur usb ....et creer un bios recovery sur usb est apparement impossible sur ce pc .

Donc me voilà sauvé ! et vu que je ne lache rien (avant j'etais un grand bidouilleur) il faut que je reprenne mon "big challenge" de switch CG ,lol ! je ne vais pas tester sur la ptite quand il y a une grosse puce presente ....

  • J'aime 1

Partager ce message


Lien à poster

Salut !
Content que tu t'aies sorti d'affaire. :c_happy:

il y a une heure, tiger13 a dit :

ce que je trouve carrement bizarre ,c'est le fait que SANS source d'alim (batterie&cordon retirés) le fait d'enlever la pile CM 10 minutes (pas de jumper sur ce pc portable) + appuie long sur le bouton de demarrage pour l'électricité résiduelle N'AIE RIEN FAIT !!! tout les parametres sont toujours là ,sauf la date et heure ! la pile sert à rien sur ce pc ,mdr !!! 

Effectivement, la mémoire n'est pas forcément volatile pour les réglages du BIOS et la pile ne sert pas forcément à la garder. Dans ce cas, pour flasher la mémoire des réglages, il faut établir un contact électrique sur un cavalier particulier alors que le PC est sous tension (ou en l'allumant).

il y a une heure, tiger13 a dit :

2eme choses : malgré les tutos (qu'on trouve meme chez HP)  ,impossible de flasher le bios par un fichier en .bin sur usb ....et creer un bios recovery sur usb est apparement impossible sur ce pc .

Alors là, je ne saurais dire…

il y a une heure, tiger13 a dit :

Donc me voilà sauvé ! et vu que je ne lache rien (avant j'etais un grand bidouilleur) il faut que je reprenne mon "big challenge" de switch CG ,lol ! je ne vais pas tester sur la ptite quand il y a une grosse puce presente ....

Tu parles de basculer l'affichage entre la sortie de la carte mère et celle de ta carte graphique additionnelle ?

Partager ce message


Lien à poster

pour la bascule ,c'est à l'interieur du pc portable ,sur la CM . il y a un chipset hd4250 et une mobility hd 5470 .

Partager ce message


Lien à poster
Posté(e) (modifié)

Yop là,

Type :

Pilote-Carte graphique

Version:

8.712.1.2000 Rev. A

Système d'exploitation :

Windows 7 (64 bits)

Date de parution :

13 août 2010

Nom de fichier :
sp49517.exe

(127.8 MB)

Correctifs et améliorations:

Apporte un support aux cartes graphiques ATI Mobility Radeon HD5650 et HD5470.
le problème est que tu dois installé le drivers d’abord la petite ... puis ensuite la grosse
et a ce moment là tu aura des réglages a faire dans le programme catalyst
le passage entre les deux se fait par un switch ( souvent connu comme le optimus )
il y a moyen de faire travailler que la grosse mais cela se passe encore dans les reglage du programme.
 
Ce package contient le pilote graphique haute définition AMD et la solution Catalyst Control Center destinés aux ordinateurs portables pris en charge exécutant un système d'exploitation pris en charge. Pour les ordinateurs portables disposant de modes graphiques commutables, ce package contient des pilotes pour les deux processeurs graphiques. Les modes graphiques commutables permettent aux utilisateurs de basculer du mode graphique à économie d'énergie (utilisé lorsque l'ordinateur fonctionne sur batterie) au mode graphique hautes performances. Ce package installe également le pilote audio HDMI (High-Definition Multimedia Interface) si le système est doté d'une sortie vidéo HDMI.
Modifié par Delta

Partager ce message


Lien à poster

C'est exactement ce que j'ai actuellement sur W7 .

Il est un peu penible ce systeme de double environnements graphique ! j'avais fait un test en désactivant la petite via le gestionnaire de périphériques windows ,bah...la grosse saute aussi . mais en faisant l'inverse ,ça ne fait pas desactiver la petite par contre . Sous W7 ,sur le site AMD , les drivers ne veulent pas marcher non plus ...et le comble du comble si je ne me trompe pas ,"je crois" bien que c'est AMD lui-même qui a inventé le chipset de gestion M880G et ils sont pas foutu d'en assumer le support et le plus etrange,il ont des drivers de ce truc mais quand j'ai tenté d'installer ce support,ça m'as sorti que j'avais pas ça  sur mon pc ! mdr... 

https://www.amd.com/en/support/chipsets/amd-8-series-chipsets/880g

 

 

Partager ce message


Lien à poster
Posté(e) (modifié)

bon ! y a du grand nouveau !!! :blush:

A force d'obstination avec un esprit ultra borné et motivé  ( on a RIEN tenté si on a pas TOUT tenté ) ,j'ai apparement reussit mon but !!! chaud-patate !!! :tongue:

mes actions ,pour ceux qui passeraient par là ,en trace ET qui ont la même version de bios que moi (y a quelques modèles)   :

"n" ième cramage de google à gogo .,je compte plus...et je suis tombé sur le meme cas que moi ,avec une solution que j'avais sous les yeux en plus ...

J'ai repris le dossier du bios débloqué (par un certain Donovan de "bios-mods" ) qui comporte 4 bios en .bin , j'avais testé d'abord le xxxxx_AMD.bin => pas interessant ....puis xxxx_ADV.bin (panneau "advanced") => désillusion totale ! mais 2 ou 3 trucs sympas vont me manquer ,domage !) .....et enfin ALLELUIA ! avec xxxxx_DBG.bin où on peut desactiver le powerplay (c'est ça !) + regler en prime la memoire partagé . ,le reste j'y touche pas. 

(c'est ce bios ===>https://www.bios-mods.com/forum/Thread-REQUEST-HP-DV7-4035CL-BIOS-Advanced-Menu

note : renommer le .bin en enlevant juste ' _DBG " (pareil pour les 3 autres) 

puis demarrage windows .....et ouf ! 1 seule visible ! la hd5470 !!!! j'en croyais pas mes yeux tellement j'ai bataillé sec ! 

problemes rencontrés : sur le site AMD ,les drivers catalyst sur la recherche manuelle (ati mobility HD5470 ....aie ! grinçage de dents ,et ne lache rien ! j'utilise l'outil de détection auto qyi me trouve un autre Catalyst et c'est bon !!! yes...install ...il reconnait en hd5000 séries (de 2015 ,c'est bon ) MAIS tous les parametres classiques sont present dans le panneau Catalyst ,ce qui prouve bien que le driver fait son taf ,il est complet, 100% opérationnel (et à jour sur la dernière version ! )

Detail important : la peesonne qui en avait parlé quelque part a testé sur Windows 10 qui prend en charge les HD 5xxx ==> tout est ok forcement  .

pour moi ,c'est domage que W10 ne s'active pas avec les clés W7 OEM et je ne n'ai pas confiance en la tenu des "kracks" basés sur le systeme KMS (tôt ou tard ils trouveront à bloquer ,je parie  ) 

Donc si pas de solution je sens que Linux (Mint Cinnamon 64bits ) va gazer là dessus  ...mais ça fait peur var une autre conception . Les Linuxiens purs et durs font peur aussi ! ce monde qui parait sectaire faudrait bouffer de la doc brute pas toujours facile (voire indigeste) où tres franchement on ne peut rien faire si on ne sait pas ce qu'on fait ....et aussi bouffer du terminal pour l'utiliser ,regler les problèmes ...y a pas d'outil auto de résolution  ....

 

 

 

 

Modifié par tiger13
  • Plusser (+1) 1

Partager ce message


Lien à poster
Il y a 7 heures, tiger13 a dit :

Les Linuxiens purs et durs font peur aussi ! ce monde qui parait sectaire faudrait bouffer de la doc brute pas toujours facile (voire indigeste) où tres franchement on ne peut rien faire si on ne sait pas ce qu'on fait ....et aussi bouffer du terminal pour l'utiliser ,regler les problèmes ...y a pas d'outil auto de résolution  ....

yop là,

c'est sectaire car c'est un autre monde de Windows...

chacun des groupes ce font peur...

sur Linux que cela soit Linux mint ou autre c'est forcement du terminal et des lignes de codes a tour de bras.

 

J'ai déjà parler a des personnes qui sont sur Linux depuis leur enfance et qui n'avais ou qui ont jamais connu de Windows meme pas un Xp ou Vista et bien les windowsien pour eux sont un groupuscule sectaire aussi et les pannes et soluce sont pour eux des bibles indigeste, car, sur windows, les bug aléatoire voir impensable c'est pas ce qui manque.. :yo-dawg:

 

  • Triste 1

Partager ce message


Lien à poster

salut @Delta !

....et pour rajouter du "bordel" à cet univers ,y a plein de devs de distribs qui veulent se detacher de cette "geek-attitude" en proposant des trucs un maximum stable&graphique ,minimisant l'utilisation à l'extreme du terminal avec un superbe Store frais aussi attractif que Android/apple-store ...heu microsoft c'est LOL ! hum..) ,en gros exactement comme windows: on installe simplement et tout est ok ! ce sont des distribs ,comme ubuntu  et surtout Mint en tete car ils veulent ouvrir au gratuit proprio ,ils font cette ouverture et c'est payant car la plus populaire ! ils sont sur le bon chemin !!! un geand bravo !!! et cela rencontre du succes sur des windowsiens&MacUsers qui en ont marre.....mais voila ...du coup on dirait presque en apparence que ça deprime ces Linuxiens purs&durs car ennuyeux,lol ! ils veulent toujours faire des trucs dessus on dirait ,ils aiment la complexité ,ils veulent "indirectement" bouffer du terminal du script...etc...ils veulent garder le controle de la machine mais en fait ils le perdent car ces distribs populaire se chargent de tout (presque à la windowsiennne ) ,donc ces distribs ne sont pas pour eux ,il y a Arch &Co si ils veulent où une base Debian et ils n'ont qu'à monter leur trucs perso...c'est pas ce qui manque en distrib .

Au fait par curiosité ! pour ces pc HP dv6 ,comment on fait un VRAI clearcmos (un reset complet du bios) en cas de plantage ???  car comme j'ai dis,enlever simplement la pile n'as rien fait !  

Et à propos des memoires graphiques dédiés/partagés ,on conseille quoi ? "auto" ou fixer une valeur ?.... ou laisser la dedié (ma hd5470 a 512 Mo ) ? 

  • J'aime 1

Partager ce message


Lien à poster
Il y a 3 heures, tiger13 a dit :

Au fait par curiosité ! pour ces pc HP dv6 ,comment on fait un VRAI clearcmos (un reset complet du bios) en cas de plantage ???  car comme j'ai dis,enlever simplement la pile n'as rien fait !  

yop là,

si il y a une pile mais pas de jumper tel que ici :

bios_zero_04.png

alors il y a toute les chances que cela soit deux point a shunter avec un trombone ou autres

pour cela il me faudrait la marque et le modèle et le numéro de série inscrite sur la CM donc avoir la carte en main du moins bien denudé et regarder un numéro de série etc.

 

  • J'aime 1

Partager ce message


Lien à poster
Posté(e) (modifié)

heu...faut des speccy (de piriform),aida ou autres là...:blink: pour qu'on me sorte ce qu'il y a ,car demonter ce pc ,pioufff !!! :laugh: je l'ai fais 1 fois pour les pates thermique et j'ai passé un sacré moment de solitude ! 

mais si il est censé avoir un jumper à coté de la pile comme sur CM de tour-pc (la pile est super accessible en ôtant juste 1 plaque sur mi  portable ) bah....y a rien ! 

Modifié par tiger13

Partager ce message


Lien à poster
il y a 23 minutes, tiger13 a dit :

mais si il est censé avoir un jumper à coté de la pile comme sur CM de tour-pc (la pile est super accessible en ôtant juste 1 plaque sur mi  portable ) bah....y a rien ! 

oui mais a ce moment là si il n'y as pas de jumper c'est une shuntage sur deux point de soudure.

Eee_clear_cmos.jpg

mais pour cela il faut avoir des screen de bonne qualité etc. et voir avec le numéro de carte mère

Partager ce message


Lien à poster

.....et faut démonter pour ça ?!:risitas-pleure2:

 

Du coup ,changement de programme !!! je comptais mettre Linux mais finalement j'ai installé Windows 10 ! qui s'est activé tout seul !!!! magique !!!! 

et vive la HD 5000 !!!!! youpi ..... aucun soucis !!! ça a l'air de bien marcher sur ce bien vieux portable ...

  • J'aime 1

Partager ce message


Lien à poster

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Restaurer la mise en forme

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


×
×
  • Créer...