Aller au contenu
guillaume

Ubuntu ne reconnais pas windows pour installer le dual boot

Messages recommandés

Bonjour,

J'ai scrupuleusement suivi le tutoriel pour installer ubuntu en dual boot avec Windows 10 cependant au moment de l'installation, il ne m'est pas proposé d'installer ubuntu à coté de windows boot manager. Il est écrit qu'aucun système d'exploitation n'est trouvé sur mon disque dur.... Après moultes recherches je n'ai trouvé aucune solution à mon problème...
J'ai pourtant bien désactivé le démarrage rapide de windows et supprimé le RAID  mais rien n'y fait mon OS n'est pas reconnu ...
Je me demandais donc si à tout hasard vous aviez quelques idées afin de m'aider à résoudre ce problème..

Je vous remercie d'avance pour l'aide que vous allez m'apporter.

Modifié par guillaume

Partager ce message


Lien à poster

Bonjour @guillaume,

J'ai eu le même problème lors du premier dual-boot que j'ai tenté, la solution a été de réinstaller W (en conservant documents et applications bien entendu).

Partager ce message


Lien à poster

Bonjour @zelandonii,

Est-ce possible de réinstaller Windows sans perdre applications et fichiers ?
De plus , quand j'ai acheté mon PC,  l'OS était W8. Dois-je réinstaller W10 ou W8 ?

Merci pour ton aide.

Partager ce message


Lien à poster

Tout simplement avec cet excellent tuto.

https://lecrabeinfo.net/reparation-reinitialiser-reparer-windows-10-sans-perdre-ses-donnees.html

Lis le entièrement et attentivement en entier avant de choisir la méthode qui te convient le mieux, sachant que c'est la n°2 qui te permet de conserver fichiers et applications.

Tu peux sans aucun problème réinstaller W10.

Modifié par zelandonii

Partager ce message


Lien à poster

Le tuto est bien fait , j'ai réussi à réinstaller W10 sans perdre aucune données ni application cependant je ne peux toujours pas utiliser l'option Dual Boot lors de l'installation d'Ubuntu...

Partager ce message


Lien à poster
il y a 27 minutes, guillaume a dit :

Le tuto est bien fait , j'ai réussi à réinstaller W10 sans perdre aucune données ni application cependant je ne peux toujours pas utiliser l'option Dual Boot lors de l'installation d'Ubuntu...

est ce que tu as réussi à installer ubuntu ? ou bien tu ne peux toujours pas l'installer ?

Partager ce message


Lien à poster

@mehdibleu, ce que @guillaume veut dire c'est qu'il ne peut installer U en dual-boot car l'installateur ne détecte pas W. @guillaume, je te propose de formater ta clé U, télécharger de nouveau le fichier ISO, réinstaller ta clé et retenter l'installation.

  • J'aime 1

Partager ce message


Lien à poster

J'ai refait la clef avec l'installateur Ubuntu mais rien n'y fait...

Cependant,  j'ai l'impression que mon windows met plus longtemps pour s'allumer et s'éteindre suite à la réinstallation...

Partager ce message


Lien à poster

Alors là, je commence a être à court de solution. Quand tu as réinstallé W, as-tu créé une clé à partir du fichier ISO téléchargé? Ou d'une autre manière ?

Partager ce message


Lien à poster

Re,

bon alors voici ce que j'ai trouvé sur des forums anglais concernant ce probleme :

Citation

Assurez-vous que vous avez désactivé le démarrage rapide dans Windows et effectuez un arrêt complet en maintenant la touche Maj enfoncée lorsque vous cliquez sur Arrêter pour désactiver le démarrage rapide. Si vous ne le faites pas, la partition Windows ne peut pas être montée par Linux pour vérifier qu’il existe une partition Windows.

et voici une autre solution, il est mentionné que le "secure boot" dans le bios peut etre à l'origine du probleme que tu rencontres :

Citation

Je sais que c'est trop tard pour OP, mais pour quiconque googler, pour moi, c'était le "secure boot". J'ai d'abord essayé de désactiver le "secure boot" via le BIOS, mais pour une raison quelconque, l'option était cachée derrière CSM  que j'ai désactivé, puis je pouvais désactiver le démarrage sécurisé. J'ai ensuite été autorisé à installer Ubuntu à côté de Windows.

j'espere que l'une de ces 2 solutions pourra resoudre ton souci.

Partager ce message


Lien à poster

zelandonii ,

Je n'ai pas réinstallé W avec un ISO mais avec l'outil Création de média (les deux possibilités étaient mentionnés dans le tuto)

mehdibleu,

J'ai bien désactivé le démarrage rapide et le secure boot. Cependant, CSM est activé mais je n'ai pas bien saisi  ce que c'était ..

Je précise que mon HDD est en MBR  et pas de UEFI (ça non plus j'ai pas ultra bien saisi...).

Partager ce message


Lien à poster

Je ne dois pas enlever CSM car si je le désactive je ne peux plus boot sur Windows...

  • Plusser (+1) 1

Partager ce message


Lien à poster
Il y a 4 heures, guillaume a dit :

Je ne dois pas enlever CSM car si je le désactive je ne peux plus boot sur Windows...

oui pardon, tu as raison, il faut laisser CSM activé dans ton cas.

dis moi quel outil tu as utilisé pour rendre une clé usb bootable avec ubuntu ?

Si tu as créé un clé bootable avec ubuntu en UEFI alors tu peux etre sûr que le probleme vient de la, du moment que ton windows 10 a été installé en legacy bios (CSM), il faut que ubuntu soit lui aussi installé avec le meme mode de configuration (CSM).

donc utilise rufus et fais en sorte que ce soit le mode "MBR pour bios" qui soit selectionné avant de créer la clé usb et tu vois ce qui se passe.

Partager ce message


Lien à poster

J'ai bien créer un clef USB bootable avec Rufus. J'ai bien choisi la fonctionnalité MBR pour "Bios ou UEFI " (il n'y a pas juste Bios ou juste UEFI) cependant, j'ai quand même l'impression que la clef se lance en UEFI a partir du Bios...

Partager ce message


Lien à poster
il y a 14 minutes, guillaume a dit :

J'ai bien créer un clef USB bootable avec Rufus. J'ai bien choisi la fonctionnalité MBR pour "Bios ou UEFI " (il n'y a pas juste Bios ou juste UEFI) cependant, j'ai quand même l'impression que la clef se lance en UEFI a partir du Bios...

pour que ce soit clair, quel mode est configuré dans ton bios ? UEFI ? UEFI + Legacy bios ? legacy bios ?

si ton bios n'est pas configuré en UEFI alors il n'y a aucune raison que la clé se lance en UEFI.

Partager ce message


Lien à poster

@guillaume

Je pense que ce probleme que tu rencontres ne peut venir que de la configuration du bios.

voila ce que tu vas faire, tu vas recréer ta clé bootable ubuntu avec rufus mais cette fois tu telecharges la derneire version de rufus (3.4), la derniere version fait en sorte de créer une clé bootable en focntion du mode bios deja configuré dans le bios.

Donc tu lances rufus depuis windows 10 sur la machine sur laquelle tu veux faire un dual boot et tu crée ta clé bootable, tu bootes avec et tu vois ce qui se passe.

si cela ne donne rien, essaie cette solution (trouvée sur un forum anglais)

Vous devrez le faire sous Windows:

    ouvrez le panneau de configuration puis  chosiissez "options d'alimentation"
    cliquez sur "choisir l'action du bouton d'alimentation"
    cliquez sur "Modifier les parametres actuellement non disponibles"
    décocher démarrage rapide
    fermez le panneau de configuration
    ouvrir une fenêtre d'invite de commande administrative
    tapez powercfg / h off (désactive l'hibernation)
    tapez chkdsk /f c:
    approuver que chkdsk s'exécute au prochain démarrage
    redémarrer Windows

 

Partager ce message


Lien à poster

J'ai effectué les solutions que tu viens de me proposer mais rien a changé.

Quand je regarde comment est fait mon Bios , je ne trouve pas si c'est UEFI ou Legacy bios... Le seul truc que j'ai trouvé c'est "Hérité".

Ensuite, j'ai 4 partitions sur mon HDD , est-ce que ça pourrait venir de là ?

Partager ce message


Lien à poster
il y a 4 minutes, guillaume a dit :

J'ai effectué les solutions que tu viens de me proposer mais rien a changé.

Quand je regarde comment est fait mon Bios , je ne trouve pas si c'est UEFI ou Legacy bios... Le seul truc que j'ai trouvé c'est "Hérité".

Ensuite, j'ai 4 partitions sur mon HDD , est-ce que ça pourrait venir de là ?

Hérité veut dire Lagacy bios (bios traditionnel)

un screen serait le bienvenue, va dans gestion des disques et tu fais stp un screen

bon va dans "gestion des disques" et puis tu va sur "disque 0" (celui qui correspond au HDD sur lequel est installé win10", tu fais cliques droit puis "proprietes" puis tu vas dans l'onglet "volume " et tu me dis tu vois apparaitre "GPT"

Partager ce message


Lien à poster

image.png.cd427f5e8c0a4eb18892a8b192f40032.png

Voilà pour gestion des disques . La partie non allouée est pour installer Ubuntu.

Les 929 Mo, c'est une partition de récupération.

image.png.a48ccce954c96cc96594e4f25f9d72b9.png

et voici pour les propriétés. Pas de GPT visiblement...

Modifié par guillaume

Partager ce message


Lien à poster

Ah bein tout s'explique alors. :)

Les disques MBR ne peuvent contenir que 4 partitions maximum et donc tu ne peux pas prétendre installer ubuntu sur une partition  supplémentaire ce qui explqiue pourquoi ubuntu ne reconnait windows lorsque tu veux l'installer en dual boot.

Partager ce message


Lien à poster

AH ben oui alors ! Du coup ça voudrait dire que s'en est fini pour le dual boot ... ? (snif...)

Partager ce message


Lien à poster
à l’instant, guillaume a dit :

AH ben oui alors ! Du coup ça voudrait dire que s'en est fini pour le dual boot ... ? (snif...)

oui à moins que tu décides de supprimer une des partitions mais je ne le te conseilles pas parce que tu pourrais te retrouver dans de sales draps. La seule que tu pourrais peut etre supprimer c'est la partition E:

que contient cette partition ? c'est une partition de donnée ? est ce qu'elle contient des dossiers telechargements (des fichiers qui sont directements transférés vers la partition E à partir de C: apres leur telechargement ) qui sont en lien direct avec la partitiion c: ?

il aurait fallu l'installer en UEFI et tu aurais pu créer autant de aprtitions que tu le souhaites (max 128)

 

Partager ce message


Lien à poster

Effectivement, je pense que si les partitions sont comme cela, c'est qu'il y a une raison...

La partition E contient seulement des données. Il ne me semble pas qu'il y ait quoi que ce soit qui transite automatiquement entre C et E.

Le problème c'est que c'est pas moi qui ait installé ce disque . C'est un réparateur qui me l'a installé suite au cassage de l'original....

Il n'y a pas moyen de passer de MBR à UEFI sans tout recommencer à zéro ?

Partager ce message


Lien à poster
à l’instant, guillaume a dit :

Effectivement, je pense que si les partitions sont comme cela, c'est qu'il y a une raison...

La partition E contient seulement des données. Il ne me semble pas qu'il y ait quoi que ce soit qui transite automatiquement entre C et E.

Le problème c'est que c'est pas moi qui ait installé ce disque . C'est un réparateur qui me l'a installé suite au cassage de l'original....

Il n'y a pas moyen de passer de MBR à UEFI sans tout recommencer à zéro ?

Non pas que je sache.

Il n'est pas recommandé de le faire en général parce que pendant la conversion, il y a un risque pour que l'utilisateur perde toutes ses données.

Partager ce message


Lien à poster

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Restaurer la mise en forme

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


×
×
  • Créer...