Aller au contenu
Mreve

Les mésaventures d'un Renard archi épuisé

Messages recommandés

Yep,

Vous vous souvenez quand je vous ai dit que j'allais passer sous Arch linux ? Et bien figurez-vous que j'ai passé la semaine ENTIÈRE à faire fonctionner mon PC correctement ! Tous les soirs après les cours pendant des heures... depuis dimanche dernier... Forever alone
J'ai jamais autant galéré en informatique que cette semaine !  Schtroumpf grillé

Bon alors même si je sais pertinemment que strictement personne sur le forum n'utilise de distributions basée sur Arch-linux je vais tout de même vous narrer mes mésaventures et vous expliquer comment j'ai résolu mes problèmes ! En tout cas, moi j'aurais tellement aimé tomber sur un post comme celui-ci... :sarkozy-perplexe:


Dimanche :
Je me dis qu'une après-midi entière pour installer Arch-Linux sur mon PC devrait largement suffire (SPOILER : J'avais tort !).

Alors il faut savoir qu'Arch-Linux s'installe en ligne de commande. Les GUI c'est pour les newbies. Bon déjà le clavier est en qwerty et la console est toute petite (je peux remercier mon écran 4K). Facile, je peux modifier ça :

loadkeys fr-latin1
setfont sun12x22

 

Conseil 1 : Si, comme moi, vous faîtes le changement Windows 10 -> Arch Linux, vous avez déjà une partition EFI. Supprimez-la quand même et recréez en une nouvelle. Vous pouvez gagner 256MB (la partition EFI créée par Windows fait inutilement 512MB)
Je vous conseille aussi de suivre ce guide pour l'installation plutôt que le wiki qui est beaucoup trop vague pour une première installation.

Je suis tranquillement le guide ci-dessus, tout me semble se passer à merveille. L'installation se termine et je boot avec succès. Chouette ! Bien sûr il n'y a pas d'environnement de bureau. Il faut l'installer. Problème ! Je n'ai pas plus accès à internet. Le package pour gérer la wifi n'était pas inclus dans les packages de base. Bien évidemment, j'avais pas mon adaptateur USB-RJ45 sous la main (j'ai pas de port RJR5). Super ! C'est parti pour la ré-installation. :relax:

En vrai je n'étais pas obligé, j'aurais très bien pu faire un arch-chroot en bootant sur ma clef USB avec l'ISO (qui contient les packages pour la wifi) et les télécharger mais je n'avais pas encore compris ça à ce moment.

Bref pendant l'installation si vous voulez tout faire en wifi, pensez à ajouter dialog et wpa_supplicant :

pacstrap -i /mnt base base-devel dialog wpa_supplicant

N'installez pas non plus NetworkManager (du moins pas tout de suite comme c'est fait dans le guide). Il entre en conflit avec wifi-menu et vous empêchera de vous connecter en wifi via wifi-menu (le plus simple à faire sans GUI). Si vous l'installez, pensez à stopper et désactiver au démarrage son service associé :

systemctl stop NetworkManager.service
systemctl disable NetworkManager.service


Les vrais problèmes arrivent maintenant ! :drhouse:

Bon déjà mon PC veut pas redémarrer. Apparemment il n'arrive pas à démonter une partition. Je suis obligé de le hard-reboot. Je suis moyennement en confiance mais je me dis que je verrais ça après.

Je suis un type normal moi, j'installe un environnement de bureau. J'ai installé Gnome (oui oui je sais j'avais dit Pantheon mais il s'avère qu'il n'est pas officiellement supporté par Arch et qu'on peut avoir un rendu similaire en bidouillant un peu avec Gnome).

Eeeeh voilà mon premier black screen ! Youhou... après 4-5h de galère (le problème du wifi m'a bien pompé du temps) mes ennuis ne font que commencer ! :macron-doute:

Je réfléchis un peu, je me dis black screen = problème de drivers graphiques. Je me renseigne un peu sur internet. J'ai pas de bol les PC Nvidia Optimus (GPU Intel + GPU Nvidia) ont souvent ce problème.

À ce moment là j’apprends à faire un chroot. J'aurais vraiment dû apprendre à le faire plus tôt parce que c'est life-changing ce truc. Avec ça tu peux tout dépanner. Depuis un ISO arch, ça te permet de changer de répertoire root et repasser ainsi sur le système à dépanner. J'ai donc pu installer bumblebee qui est l'implémentation libre de Nvidia Optimus.

sudo pacman -S bumblebee

Pfiou ! Enfin ! Il est 23h et j'ai enfin une interface graphique ! :likeaboss:

Lundi :
Je rentre tard le soir donc je n'ai pas le temps
de terminer ma configuration.

Mardi :
Ça devient intéressant. J'essaie de comprendre comment faire fonctionner le switch de GPU. Bumblebee n'a pas l'air de bien fonctionner. Ma NVIDIA GTX 960M est toujours activée et moi j'aimerais bien que ça soit la carte Intel qui soit activée par défaut. Je commence à faire plein d'autres bidouilles en parallèles : gestion de l'énergie, modifications des paramètres de boot du kernel, installation des drivers nvidia.
Et puis vers 23h je vais pour pour éteindre mon PC.... C'est là que je me rends compte que j'en ai pas fini... et oui vous vous rappelez de ce bug ? Mon PC ne veut pas s'éteindre ou redémarrer normalement. Je suis obligé de hard-reboot. Oui hard-reboot ! Sur mon PC appuyer 5s sur la touche power le fait redémarrer, pas s'éteindre... :frustrated-boromir:

Évidement, écran noir après le boot...
Je peux vous dire que j'avais les b**les à ce moment  là. Je me suis maudit d'avoir fait autant de modifications sans redémarrer. Il était 23h30.

Et c'est là que le gros moment de flippe arrive ! Littéralement 1min après l'apparition de l'écran noir les ventilos de mon PC commencent à souffler à fond !  Spongebob Partick WHAT!?  Oh God!
 

Ah j'étais pas prêt pour ça ! J'étais d'ailleurs en train de me brosser les dents. J'ai foncé sur mon PC pour le hard-reboot en espérant que rien n'avait cramé. Bon heureusement c'était du bluff. Il n'y avait rien de chaud du tout. J'ai eu bien peur quand même mais mon PC a redémarré et l'écran noir est de nouveau là...
 

Alors ? Vous voyez venir la grosse blague ? Clooney what else?

Je me suis couché à 1h du mat' et ce sans avoir réussi à éteindre ce fichu PC ! J'ai très mal dormi. J'ai rêvé de lignes de commandes.
 

Mercredi :
Finalement, j'ai fait une clean install de Arch-Linux et je me suis rendu compte d'une chose... Arch-Linux c'est vraiment usant. Il faut tout faire manuellement et sans GUI. Pourquoi est-ce que j'ai choisi ça d'ailleurs ? :not-sure:

Quand je l'avais en live OS sur ma clef USB j'avais pas à me soucier de tout ça...

C'est là que j'ai compris que je devais passer sur Manjaro. En gros Manjaro c'est un Arch-linux user-friendly. Je voulais absolument rester sur une distro basée sur Arch-Linux (notamment pour le principe KISS). Le gros avantage aussi c'est la détection automatique du hardware et l'installation des pilotes adéquats. Manjaro est même censé fonctionner out-of-the-box avec Nvidia Optimus.

Bien sûr tout ne se passe pas comme prévu.... l'installation est beaucoup plus agréable par contre (automatisation de beaucoup de chose + GUI)

Je passe sur les détails mais j'enchaîne écran noir après écran noir. Je sais que c'est un problème de driver, j'essaie à la fois l'installation avec les drivers nvidia et puis avec les drivers libres (nouveau et video-linux) . Sans succès. :c_coldsweat:

En fait le problème c'est simplement la Nvidia GTX 960M. Pour l'heure impossible d'utiliser correctement la carte Nvidia. Je sais pas comment j'ai fait avec Arch la première fois (justement c'est bizarre j'avais rien fait de particulier)

Je me couche à 00h30.
 

Jeudi :
Je commence à être sérieusement fatigué. :c_sad:
Mais je veux absolument résoudre ce problème. Je vais accélérer la narration parce que je sens que ça fait très long là.
Bref, pour réussir à installer Manjaro j'ai dû éditer les paramètres du kernel au boot en appuyant sur la touche 'e'. Désolé, je ne n'arrive pas à trouver de capture.
J'ai mis beaucoup de temps à comprendre que l'on pouvait faire ça directement depuis l'installateur Manjaro. En gros, après la sélection du clavier, des langues et des drivers (il faut mettre "free drivers"), il faut appuyer sur 'e' en sélectionnant la case "boot xxxx". Une fois entré dans les paramètres du kernel, il faut interdire au pilote nouveau de se lancer :

nouveau.modeset=0

L'installation va se faire mais vous ne pourrez pas vous identifier à votre compte (écran noir après le loggin) parce que le paramètre n'a été sauvegardé par GRUB.

Pour ce faire il faut appuyer sur 'e' après (hard) reboot dans grub et ajouter à la fin de la chaine (avant la double quote ") commençant par linux :
 

nouveau.modeset=0


Cela vous permettra de vous logger. Pour rendre ces modifications permanentes, il faut éditer le fichier de config grub :

sudo nano /etc/default/grub

Ajoutez nouveau.modeset=0 en paramètre à :

GRUB_CMDLINE_LINUX_DEFAULT

Mettez ensuite à jour grub pour qu'il prenne en compte cette modification :

sudo grub-mkconfig -o /boot/grub/grub.cfg

 

Et voilà ! Bingo ! :first-day-on-the-internet-kid:
 

Vendredi :

J'ai passé le reste de mon jeudi après-midi et un bout de mon vendredi soir à essayer de tester différents types de drivers nividia et pour l'instant sans succès. À chaque fois ça génère des black screen après reboot.

Je ne lâche pas l'affaire ! Je mettrais à jour ce post si besoin.

Le mot de la fin : À part ce problème spécifique à certains PC, Manjaro c'est trop de la balle ! Je suis en grand kiff ! :c_inlove:

Modifié par Mreve
  • Ahah 1
  • Perplexe 1
  • Plusser (+1) 3

Partager ce message


Lien à poster

Et bien chapeau @Mreve!!!

Sinon tu avais l'installation avec Arch anywhere (j'avoue que je n'ai pas testé ces distrib linux ….pas le temps mais sur VB ça doit être sympa) https://memo-linux.com/installer-facilement-archlinux-avec-arch-anywhere/ et puis comme tu dis avec nvidia c'est pas gagné et moi ma nvidia 1070 j'y tiens ;) : PC Gamer donc linux ….

Par contre j'ai trouvé ceci pour VirtualBox http://frederic.bezies.free.fr/blog/?page_id=9453 pour ceux que ça intéresse.

 

  • Plusser (+1) 2

Partager ce message


Lien à poster

Salut ! :c_happy:

Grand bravo pour ta débrouillardise !
J'espère que les MAJ de Arch ne sont pas aussi désastreuses que celles de Windows 10, parce que là, t'es mal ! :risitas-no:

Et bon repos en tout cas. :c_tongue:

Partager ce message


Lien à poster
Le 20/10/2018 à 07:41, calisto06 a dit :

Sinon tu avais l'installation avec Arch anywhere

Oh ! Merci pour la découverte ! :c_happy:

Le 20/10/2018 à 07:41, calisto06 a dit :

puis comme tu dis avec nvidia c'est pas gagné et moi ma nvidia 1070 j'y tiens ;) : PC Gamer donc linux ….

J'ai finalement résolu TOUS mes problèmes. Je suis très content. Et le problème venait spécifiquement du combo CPU Skylake + GTX 960M. Je vais ajouter une partie II)

Sincèrement depuis que Valve a lancé Steam Proton, le gaming sous Linux c'est vraiment envisageable. Il faut simplement installer les pilotes propriétaires pour profiter au maximum des performances de  la carte graphique.

Il ne faut vraiment pas que ce post fasse peur. Mon cas reste très spécifique.

Modifié par Mreve
  • J'aime 1

Partager ce message


Lien à poster

Pour ceux que ça intéresse j'ai réussi à résoudre mes autres problèmes :

1) Impossible d'installer les drivers propriétaires + Bumblebee ==> écran noir au redémarrage

Il faut ajouter un paramètre au boot :

sudo nano /etc/default/grub

Ajouter acpi_osi=! acpi_osi=\"Windows 2009\" comme ci dessous

GRUB_CMDLINE_LINUX_DEFAULT ="quiet [...] nouveau.modeset=0 acpi_osi=! acpi_osi=\"Windows 2009\""

Mettez ensuite à jour grub pour qu'il prenne en compte cette modification :

sudo update-grub

Redémarrez et installez les drivers nvidia (ne pas installer avant le redémarrage !!)

sudo mhwd -f -i pci video-hybrid-intel-nvidia-bumblebee

Redémarrez et miracle ça marche ! Grand schtroumpf au laboratoire

N'oubliez pas d'activer Bumblebee au démarrage du PC

sudo systemctl enable bumblebeed  [le "d" n'est pas une erreur de frappe]

Pour lancer un programme en utilisant le GPU Nvidia, il vous suffit de faire :

optirun nom_du_programme

Vous pouvez vérifier que les drivers de la carte graphique nvidia sont correctement installés :

optirun -b none nvidia-settings -c :8


1) Steam buggé as f*ck impossible de lancer un jeu

Il faut lancer steam avec la carte graphique Nvidia, pas Intel.

Vérifiez bien que vous n'avez installer que Steam-manjaro et pas Steam-native. Téléchargez ensuite virtualgl

sudo pacman -S virtualgl lib32-virtualgl lib32-primus primus

Si le problème n'est pas réglé en lançant Steam avec optirun, essayez ça :

LD_PRELOAD="libpthread.so.0 libGL.so.1" __GL_THREADED_OPTIMIZATIONS=1 optirun steam

C'est ce qui a réglé mon problème.

Partager ce message


Lien à poster

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×
pizzicato-practitioner