Aller au contenu
maximushugus

[TUTO] Installer LEDE / OpenWRT sur un routeur Xiaomi Routeur 3G

Messages recommandés

Il y a 9 heures, acetone802000 a dit :

Bonjour,

Merci pour tes liens

Une petite question concernant le passage vers OpenWRT version stable:

J'ai commandé il y a 2 semaines un 3G sur Gearbest, donc d'ici une quinzaine de jours je devrais le recevoir.

Je compte le passer immédiatement en OpenWRT stable.

Suis-je obligé de passer par ton tuto ou il est possible de flasher directement le .tar d'OpenWRT ?

Je me répond à moi-même... Apparemment non.

 

Merci

Partager ce message


Lien à poster

Bonjour tout le monde ,

Je rentre dans le sujet direct :).

J'ai acheté un MiWifi 3G sur Aliexpress qui n'a jamais démarré correctement (bootloop). Apres une bataille acharné avec le vendeur  je n'es jamais été remboursé (cause : preuves de non fonctionnement insuffisantes).

Fin bref j'ai décidé d'acheter un adaptateur serial USB 3,3V  que j'ai soudé tant bien que mal :) pour essayer de la Debug ou au moins voir ce qu'il disait .

Apres analyse du Uboot j'ai remarqué qu'un OpenWRT avait ete "mal installé" sur "mon routeur neuf" (un retour non testé je suppose )

Citation

3: System Boot system code via Flash.
## Booting image at bc600000 ...
   Image Name:   MIPS OpenWrt Linux-4.9.67
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    1675118 Bytes =  1.6 MB
   Load Address: 80001000
   Entry Point:  80001000
..........................   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK
commandline uart_en=0 factory_mode=0 usb_u3=0
No initrd
## Transferring control to Linux (at address 80001000) ...
## Giving linux memsize in MB, 256

Le problème est que je n'arrive pas prendre la main sur le prompt et tout va très vite dans le menu suivant.

Citation

Please choose the operation:
   1: Load system code to SDRAM via TFTP.
   2: Load system code then write to Flash via TFTP.
   3: Boot system code via Flash (default).
   4: Entr boot command line interface.
   7: Load Boot Loader code then write to Flash via Serial.
   9: Load Boot Loader code then write to Flash via TFTP.

You choosed 3
                                                                                                                                                                      0
Booting System 2
..ranand_erase: start:80000, len:20000
..Done!
done

Donc ma question est :

Qui a deja eu un bootloop et a repris la main pour le debug ?

Savoir si il y a un manip ?

 

Merci pour les potentiel réponses et bon dimanche 

 

Uboot complet 

Révélation

===================================================================
                MT7621   stage1 code done
                CPU=50000000 HZ BUS=12500000 HZ
===================================================================


U-Boot 1.1.3 (Jul 13 2017 - 17:10:56)

Board: Ralink APSoC DRAM:  256 MB
Power on memory test. Memory size= 256 MB...OK!
relocate_code Pointer at: 8ffac000

Config XHCI 40M PLL
******************************
Software System Reset Occurred
******************************
Allocate 16 byte aligned buffer: 8ffdff50
Enable NFI Clock
# MTK NAND # : Use HW ECC
NAND ID [C8 D1 80 95 40]
Device not found, ID: c8d1
Not Support this Device!
chip_mode=00000001
Support this Device in MTK table! c8d1
select_chip
[NAND]select ecc bit:4, sparesize :64 spare_per_sector=16
Signature matched and data read!
load_fact_bbt success 1023
load fact bbt success
[mtk_nand] probe successfully!
mtd->writesize=2048 mtd->oobsize=64,    mtd->erasesize=131072  devinfo.iowidth=8
..============================================
Ralink UBoot Version: 5.0.0.0
--------------------------------------------
ASIC MT7621A DualCore (MAC to MT7530 Mode)
DRAM_CONF_FROM: Auto-Detection
DRAM_TYPE: DDR3
DRAM bus: 16 bit
Xtal Mode=5 OCP Ratio=1/4
Flash component: NAND Flash
Date:Jul 13 2017  Time:17:10:56
============================================
icache: sets:256, ways:4, linesz:32 ,total:32768
dcache: sets:256, ways:4, linesz:32 ,total:32768

 ##### The CPU freq = 880 MHZ ####
 estimate memory size =256 Mbytes
#Reset_MT7530
set LAN/WAN LWLLL

Please choose the operation:
   1: Load system code to SDRAM via TFTP.
   2: Load system code then write to Flash via TFTP.
   3: Boot system code via Flash (default).
   4: Entr boot command line interface.
   7: Load Boot Loader code then write to Flash via Serial.
   9: Load Boot Loader code then write to Flash via TFTP.

You choosed 3
                                                                                                                                                                      0
Booting System 2
..ranand_erase: start:80000, len:20000
..Done!
done

3: System Boot system code via Flash.
## Booting image at bc600000 ...
   Image Name:   MIPS OpenWrt Linux-4.9.67
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    1675118 Bytes =  1.6 MB
   Load Address: 80001000
   Entry Point:  80001000
..........................   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK
commandline uart_en=0 factory_mode=0 usb_u3=0
No initrd
## Transferring control to Linux (at address 80001000) ...
## Giving linux memsize in MB, 256

Starting kernel ...

[    0.000000] Linux version 4.9.67 (terminator@SC-GAME) (gcc version 6.3.0 (OpenWrt GCC 6.3.0 r5508-1337c2b) ) #0 SMP Thu Dec 14 13:53:12 2017
[    0.000000] SoC Type: MediaTek MT7621 ver:1 eco:3
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 0001992f (MIPS 1004Kc)
[    0.000000] MIPS: machine is Xiaomi Mi Router 3G
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 10000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] VPE topology {2,2} total 4
[    0.000000] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.000000] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x000000000fffffff]
[    0.000000]   HighMem  empty
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x000000000fffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x000000000fffffff]
[    0.000000] percpu: Embedded 12 pages/cpu @8120f000 s17744 r8192 d23216 u49152
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 65024
[    0.000000] Kernel command line: console=ttyS0,115200n8 rootfstype=squashfs,jffs2
[    0.000000] PID hash table entries: 1024 (order: 0, 4096 bytes)
[    0.000000] Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
[    0.000000] Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)
[    0.000000] Writing ErrCtl register=000151c0
[    0.000000] Readback ErrCtl register=000151c0
[    0.000000] Memory: 254024K/262144K available (3926K kernel code, 218K rwdata, 900K rodata, 256K init, 267K bss, 8120K reserved, 0K cma-reserved, 0K highmem)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=4, Nodes=1
[    0.000000] Hierarchical RCU implementation.
[    0.000000] NR_IRQS:256
[    0.000000] clocksource: GIC: mask: 0xffffffffffffffff max_cycles: 0xcaf478abb4, max_idle_ns: 440795247997 ns
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 4343773742 ns
[    0.000010] sched_clock: 32 bits at 440MHz, resolution 2ns, wraps every 4880645118ns
[    0.007788] Calibrating delay loop... 586.13 BogoMIPS (lpj=2930688)
[    0.070415] pid_max: default: 32768 minimum: 301
[    0.075136] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.081662] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.093230] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.093242] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.093254] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.093413] CPU1 revision is: 0001992f (MIPS 1004Kc)
[    0.177427] Synchronize counters for CPU 1:
[    0.177428] done.
[    0.188770] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.188779] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.188786] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.188876] CPU2 revision is: 0001992f (MIPS 1004Kc)
[    0.269427] Synchronize counters for CPU 2:
[    0.269428] done.
[    0.277235] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.277242] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.277249] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.277345] CPU3 revision is: 0001992f (MIPS 1004Kc)
[    0.354601] Synchronize counters for CPU 3:
[    0.354602] done.
[    0.360836] Brought up 4 CPUs
[    0.364498] devtmpfs: initialized
[    0.371454] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.381247] futex hash table entries: 1024 (order: 3, 32768 bytes)
[    0.387495] pinctrl core: initialized pinctrl subsystem
[    0.393275] NET: Registered protocol family 16
[    0.433078] pull PCIe RST: RALINK_RSTCTRL = 4000000
[    0.738437] release PCIe RST: RALINK_RSTCTRL = 7000000
[    0.743488] ***** Xtal 40MHz *****
[    0.746840] release PCIe RST: RALINK_RSTCTRL = 7000000
[    0.751939] Port 0 N_FTS = 1b105000
[    0.755416] Port 1 N_FTS = 1b105000
[    0.758849] Port 2 N_FTS = 1b102800
[    1.914179] PCIE2 no card, disable it(RST&CLK)
[    1.918546]  -> 21007f2
[    1.920938] PCIE0 enabled
[    1.923530] PCIE1 enabled
[    1.926127] PCI host bridge /pcie@1e140000 ranges:
[    1.930910]  MEM 0x0000000060000000..0x000000006fffffff
[    1.936063]   IO 0x000000001e160000..0x000000001e16ffff
[    1.941266] PCI coherence region base: 0x60000000, mask/settings: 0xf0000002
[    1.982740] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    1.988680] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    1.994522] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    2.001624] PCI host bridge to bus 0000:00
[    2.005657] pci_bus 0000:00: root bus resource [mem 0x60000000-0x6fffffff]
[    2.012657] pci_bus 0000:00: root bus resource [io  0xffffffff]
[    2.018472] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0]
[    2.025233] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[    2.035194] pci 0000:00:00.0: BAR 0: no space for [mem size 0x80000000]
[    2.041736] pci 0000:00:00.0: BAR 0: failed to assign [mem size 0x80000000]
[    2.048618] pci 0000:00:01.0: BAR 0: no space for [mem size 0x80000000]
[    2.055194] pci 0000:00:01.0: BAR 0: failed to assign [mem size 0x80000000]
[    2.062103] pci 0000:00:00.0: BAR 8: assigned [mem 0x60000000-0x600fffff]
[    2.068854] pci 0000:00:01.0: BAR 8: assigned [mem 0x60100000-0x601fffff]
[    2.075578] pci 0000:00:01.0: BAR 9: assigned [mem 0x60200000-0x602fffff pref]
[    2.082765] pci 0000:00:00.0: BAR 1: assigned [mem 0x60300000-0x6030ffff]
[    2.089487] pci 0000:00:01.0: BAR 1: assigned [mem 0x60310000-0x6031ffff]
[    2.096246] pci 0000:01:00.0: BAR 0: assigned [mem 0x60000000-0x600fffff]
[    2.102970] pci 0000:00:00.0: PCI bridge to [bus 01]
[    2.107905] pci 0000:00:00.0:   bridge window [mem 0x60000000-0x600fffff]
[    2.114637] pci 0000:02:00.0: BAR 0: assigned [mem 0x60100000-0x601fffff 64bit]
[    2.121915] pci 0000:02:00.0: BAR 6: assigned [mem 0x60200000-0x6020ffff pref]
[    2.129053] pci 0000:00:01.0: PCI bridge to [bus 02]
[    2.133993] pci 0000:00:01.0:   bridge window [mem 0x60100000-0x601fffff]
[    2.140723] pci 0000:00:01.0:   bridge window [mem 0x60200000-0x602fffff pref]
[    2.147923] BAR0 at slot 0 = 0
[    2.150908] bus=0x0, slot = 0x0
[    2.154024] BAR0 at slot 1 = 0
[    2.157040] bus=0x0, slot = 0x1
[    2.160175] bus=0x1, slot = 0x0, irq=0xff
[    2.164141] bus=0x2, slot = 0x1, irq=0xff
[    2.169581] clocksource: Switched to clocksource GIC
[    2.177006] NET: Registered protocol family 2
[    2.182044] TCP established hash table entries: 2048 (order: 1, 8192 bytes)
[    2.188933] TCP bind hash table entries: 2048 (order: 2, 16384 bytes)
[    2.195388] TCP: Hash tables configured (established 2048 bind 2048)
[    2.201739] UDP hash table entries: 256 (order: 1, 8192 bytes)
[    2.207498] UDP-Lite hash table entries: 256 (order: 1, 8192 bytes)
[    2.213964] NET: Registered protocol family 1
[    2.449508] 4 CPUs re-calibrate udelay(lpj = 2924544)
[    2.455906] Crashlog allocated RAM at address 0x3f00000
[    2.461671] workingset: timestamp_bits=30 max_order=16 bucket_order=0
[    2.471068] random: fast init done
[    2.477089] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    2.482874] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    2.495295] io scheduler noop registered
[    2.499133] io scheduler deadline registered (default)
[    2.504680] gpio-export gpio_export: 1 gpio(s) exported
[    2.510681] Serial: 8250/16550 driver, 3 ports, IRQ sharing disabled
[    2.518543] console [ttyS0] disabled
[    2.522117] 1e000c00.uartlite: ttyS0 at MMIO 0x1e000c00 (irq = 18, base_baud = 3125000) is a 16550A
[    2.531093] console [ttyS0] enabled
[    2.531093] console [ttyS0] enabled
[    2.537951] bootconsole [early0] disabled
[    2.537951] bootconsole [early0] disabled
[    2.547379] MediaTek Nand driver init, version v2.1 Fix AHB virt2phys error
[    2.554499] Allocate 16 byte aligned buffer: 80567130
[    2.559548] Enable NFI Clock
[    2.562417] # MTK NAND # : Use HW ECC
[    2.566075] Device not found, ID: c8d1
[    2.569825] Not Support this Device!
[    2.573554] chip_mode=00000001
[    2.576597] Support this Device in MTK table! c8d1
[    2.581556] [NAND]select ecc bit:4, sparesize :64 spare_per_sector=16
[    2.588014] nand: device found, Manufacturer ID: 0xc8, Chip ID: 0xd1
[    2.594350] nand: ESMT NAND 128MiB 3,3V 8-bit
[    2.598687] nand: 128 MiB, SLC, erase size: 128 KiB, page size: 2048, OOB size: 64
[    2.606244] Scanning device for bad blocks
[    2.755677] 10 ofpart partitions found on MTD device MT7621-NAND
[    2.761669] Creating 10 MTD partitions on "MT7621-NAND":
[    2.766963] 0x000000000000-0x000000080000 : "Bootloader"
[    2.773935] 0x000000080000-0x0000000c0000 : "Config"
[    2.780490] 0x0000000c0000-0x000000100000 : "Bdata"
[    2.786852] 0x000000100000-0x000000140000 : "Factory"
[    2.793474] 0x000000140000-0x000000180000 : "crash"
[    2.799902] 0x000000180000-0x0000001c0000 : "crash_syslog"
[    2.806827] 0x0000001c0000-0x000000200000 : "reserved0"
[    2.813589] 0x000000200000-0x000000600000 : "kernel_stock"
[    2.820594] 0x000000600000-0x000000a00000 : "kernel"
[    2.826998] 0x000000a00000-0x000007f80000 : "ubi"
[    2.834081] [mtk_nand] probe successfully!
[    2.838898] Signature matched and data read!
[    2.843172] load_fact_bbt success 1023
[    2.847552] libphy: Fixed MDIO Bus: probed
[    2.922151] libphy: mdio: probed
[    4.324881] mtk_soc_eth 1e100000.ethernet: loaded mt7530 driver
[    4.331563] mtk_soc_eth 1e100000.ethernet eth0: mediatek frame engine at 0xbe100000, irq 20
[    4.341948] NET: Registered protocol family 10
[    4.347842] NET: Registered protocol family 17
[    4.352389] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    4.365297] 8021q: 802.1Q VLAN Support v1.8
[    4.372576] UBI: auto-attach mtd9
[    4.375908] ubi0: attaching mtd9
[    5.487794] ubi0: scanning is finished
[    5.507716] ubi0: attached mtd9 (name "ubi", size 117 MiB)
[    5.513221] ubi0: PEB size: 131072 bytes (128 KiB), LEB size: 126976 bytes
[    5.520074] ubi0: min./max. I/O unit sizes: 2048/2048, sub-page size 2048
[    5.526827] ubi0: VID header offset: 2048 (aligned 2048), data offset: 4096
[    5.533765] ubi0: good PEBs: 940, bad PEBs: 0, corrupted PEBs: 0
[    5.539757] ubi0: user volume: 0, internal volumes: 1, max. volumes count: 128
[    5.546946] ubi0: max/mean erase counter: 2/1, WL threshold: 4096, image sequence number: 1125438176
[    5.556044] ubi0: available PEBs: 916, total reserved PEBs: 24, PEBs reserved for bad PEB handling: 20
[    5.565339] ubi0: background thread "ubi_bgt0d" started, PID 358
[    5.565360] hctosys: unable to open rtc device (rtc0)
[    5.576838] VFS: Cannot open root device "(null)" or unknown-block(0,0): error -6
[    5.584308] Please append a correct "root=" boot option; here are the available partitions:
[    5.592655] 1f00             512 mtdblock0 [[    5.596661]  (driver?)
[    5.599111] 1f01             256 mtdblock1  [    5.603110]  (driver?)
 [    5.605561] 1f02             256 mtdblock2  [    5.609644]  (driver?)
 5.576838] [    5.612095] 1f03             256 mtdblock3 V[    5.617031]  (driver?)
FS: Can[[    5.619477] 1f04             256 mtdblock4  [    5.624166]  (driver?)
 [    5.626617] 1f05             256 mtdblock5  [    5.630701]  (driver?)
 5.584308][    5.633152] 1f06             256 mtdblock6  [    5.638000]  (driver?)
Please a[    5.640465] 1f07            4096 mtdblock7 [[    5.645145]  (driver?)
    5.592[    5.647591] 1f08            4096 mtdblock8 6[    5.652367]  (driver?)
55] 1f00  [    5.654818] 1f09          120320 mtdblock9  [    5.659678]  (driver?)
[    5.662129] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
[    5.672558] Rebooting in 1 seconds..

===================================================================
                MT7621   stage1 code 10:33:11 (ASIC)
                CPU=50000000 HZ BUS=12500000 HZ
==================================================================
Change MPLL source from XTAL to CR...
do MEMPLL setting..
MEMPLL Config : 0x11100000
3PLL mode + External loopback
=== XTAL-40Mhz === DDR-1200Mhz ===
PLL2 FB_DL: 0x12, 1/0 = 686/338 49000000
PLL3 FB_DL: 0x15, 1/0 = 605/419 55000000
PLL4 FB_DL: 0x15, 1/0 = 564/460 55000000
do DDR setting..[00320381]
Apply DDR3 Setting...(use customer AC)
          0    8   16   24   32   40   48   56   64   72   80   88   96  104  112  120
      --------------------------------------------------------------------------------
0000:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0001:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0002:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0003:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0004:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0005:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0006:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0007:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0008:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0009:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
000A:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
000B:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
000C:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
000D:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    1
000E:|    0    0    0    0    0    0    0    0    1    1    1    1    1    1    1    1
000F:|    0    0    0    0    1    1    1    1    1    1    1    1    1    1    0    0
0010:|    1    1    1    1    1    1    1    1    1    0    0    0    0    0    0    0
0011:|    1    1    1    1    0    0    0    0    0    0    0    0    0    0    0    0
0012:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0013:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0014:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0015:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0016:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0017:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0018:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0019:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
001A:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
001B:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
001C:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
001D:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
001E:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
001F:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
rank 0 coarse = 15
rank 0 fine = 72
B:|    0    0    0    0    0    0    0    0    0    1    1    1    0    0    0    0
opt_dle value:10
DRAMC_R0DELDLY[018]=00002020
==================================================================
                RX      DQS perbit delay software calibration
==================================================================
1.0-15 bit dq delay value
==================================================================
bit|     0  1  2  3  4  5  6  7  8  9
--------------------------------------
0 |    11 7 7 10 8 7 9 7 5 7
10 |    8 9 8 9 7 9
--------------------------------------

==================================================================
2.dqs window
x=pass dqs delay value (min~max)center
y=0-7bit DQ of every group
input delay:DQS0 =32 DQS1 = 32
==================================================================
bit     DQS0     bit      DQS1
0  (1~60)30  8  (2~58)30
1  (1~59)30  9  (2~61)31
2  (0~57)28  10  (1~62)31
3  (1~60)30  11  (2~60)31
4  (1~60)30  12  (1~63)32
5  (1~60)30  13  (1~58)29
6  (1~59)30  14  (1~62)31
7  (1~63)32  15  (1~61)31
==================================================================
3.dq delay value last
==================================================================
bit|    0  1  2  3  4  5  6  7  8   9
--------------------------------------
0 |    13 9 11 12 10 9 11 7 7 8
10 |    9 10 8 12 8 10
==================================================================
==================================================================
     TX  perbyte calibration
==================================================================
DQS loop = 15, cmp_err_1 = ffff0000
dqs_perbyte_dly.last_dqsdly_pass[0]=15,  finish count=1
dqs_perbyte_dly.last_dqsdly_pass[1]=15,  finish count=2
DQ loop=15, cmp_err_1 = ffff0080
dqs_perbyte_dly.last_dqdly_pass[1]=15,  finish count=1
DQ loop=14, cmp_err_1 = ffff0000
dqs_perbyte_dly.last_dqdly_pass[0]=14,  finish count=2
byte:0, (DQS,DQ)=(8,8)
byte:1, (DQS,DQ)=(8,8)
20,data:88
[EMI] DRAMC calibration passed

 

Modifié par Le PoissonClown
Mise en forme du log Uboot

Partager ce message


Lien à poster

Je testerais ça dans la semaine j'ai tout dessoudé mon installation de fortune j'ai commandé des câbles jumper pour faire ça propre .

Merci pour ta réponse je vous tiens au courant .

 

Partager ce message


Lien à poster

Bonjour,

Est ce que la section 5) b)"On va mettre à jour le routeur via sysupgrade.tar" est utile après l'installation du dernier firmware lede ?

Je ne comprends pas pourquoi dans le tuto :

-on installe la dernière version du firmware

-on upgrade ... (ça réinstalle pas juste la même version ?)

Merci

Modifié par aaazju

Partager ce message


Lien à poster

bonsoir à tous,

Déjà merci pour ce tuto j'ai pu installer openwrt et lede bien qu'étant novice en la matière. (j'ai un peu galéré mais bon en persévérant on y arrive^^).

J'ai réussi à paramétrer le wi fi sans souci.

Par contre impossible de flasher le dernier firmware, ni même celui du tuto. Après avoir sélectionné l'image et la confirmation de l'installation, je me retrouve à chaque fois "en attente de l'application des changements" et bien qu'ayant attendu longtemps (plus de deux heures) rien ne se passe. Je précise que le routeur à bien rebooter et repassé en "bleu".

J'ai essayé de rebooter sur SSH, ça fonctionne mais je suis toujourrs sur le firmware d'origine. En plus impossible de passer la page de connexion ensuite sous LEDE.

Quelqu'un aurait une petite idée?

merci d'avance.

Modifié par Tholsa

Partager ce message


Lien à poster

Bonjour, merci pour ce billet. En relisant le tuto en anglais il se pourrait que l'adresse IP avant upgrade vers OpenWRT soit 192.168.31.1. L'adresse 192.168.1.1 étant l'adresse après le flash (?). De plus j'avais une question, sur le site OpenWRT je vois un binaire additionnel, (initramfs)  j'imagine qu'il ne faut pas l'installer?merci en tout cas!

Partager ce message


Lien à poster
Le 13/09/2018 à 10:38, aaazju a dit :

Bonjour,

Est ce que la section 5) b)"On va mettre à jour le routeur via sysupgrade.tar" est utile après l'installation du dernier firmware lede ?

Je ne comprends pas pourquoi dans le tuto :

-on installe la dernière version du firmware

-on upgrade ... (ça réinstalle pas juste la même version ?)

Merci

Bonjour,

mir3g-squashfs-kernel1.bin et mir3g-squashfs-rootfs0.bin (kernel et rootfs) sont les fichiers de base qui reste tel quel.

openwrt-ramips-mt7621-mir3g-squashfs-sysupgrade.tar est la mise jour system/paquets, l'équivalent d'un apt upgrade sous GNU/Linux si tu connais un peu.

Une commande existe sous Unix/Lede que j'ai testé, mais qui fait planter le system, donc obligation de passer par ces fichiers qui change très souvent d'ailleurs sur la version unstable.

Inconvénient, il faut tout reconfigurer à chaque fois.

D'ailleurs j'en profite pour remercier l'auteur pour son excellent tuto qui ma bien dépanné ;)

Bonne journée.

Partager ce message


Lien à poster

Hello,

j'ai réalisé l'installation aujourd'hui : didacticiel parfait => merci, merci merci (et bravo!) car pas forcément évident !

J'ai été bloqué à l'étape 5, car après le changement de l'IP en 2.1, je n'arrivais plus à me connecter en ssh au routeur (malgré plusieurs reboot). J'avais systématiquement un "connexion refused", les IP 1.1 ou 31.1 me renvoyaient un timeout. Un ipconfig sur mon PC m'indiquait bien la passerelle en 2.1 ce qui prouvait bien la bonne prise en compte du changement par le routeur. La solution a été un reset du routeur (appui 10s routeur allumé), et me voilà revenu en 1.1 et accès ssh accepté. J'ai pu ainsi terminer l'installation. Je décris ici la solution de contournement que j'ai trouvé pour aider d'éventuelle personnes ayant le même blocage :)

 

Je me pose maintenant la question de la maj sur la dernière version stable OpenWRT :

Nous avons installé ici une version LEDE "instable"

Comment passer sur la version stable OPENWRT ? J'imagine qu'il faut passer par la page de maj manuelle, par contre quel fichier mettre (je ne veux pas briquer mon routeur avec une mauvaise version) ?

Si je m'inspire du fichier de l'arbo pour la maj LEDE (étape 5 b)) et de la page dédiée au mi3G sur openWRT (https://openwrt.org/toh/xiaomi/mir3g?s[]=mi&s[]=3g), il semblerait que ce soit le fichier http://downloads.openwrt.org/releases/18.06.1/targets/ramips/mt7621/openwrt-18.06.1-ramips-mt7621-mir3g-squashfs-sysupgrade.tar

Pouvez-vous me confirmer que c'est bien ce fichier qu'il faut insérer dans la maj manuelle svp ?

Question subsidiaire : une fois cette maj effectuée, est-il nécessaire de répéter l'opétaion 5/ a) (opkg update et opkg install luci-ssl) ?

Merci pour votre aide,

 

Partager ce message


Lien à poster

Hello Gelat, j'ai moi même suivi le tuto et en ce qui concerne la maj "stable" il suffit de passer par le portail web avec le tar dont tu remis le lien, rien de plus est nécessaire, en tout cas de mon point de vue (j'ai fait la manip en milieu de semaine et il semble que les bug rencontrés sur la bande passante 2.4 Ghz ont été fix).

Partager ce message


Lien à poster

Salut ici,

 

Idem, installé hier, impossible de changer l'ip sans défaut de connexion SSH, si quelqu'un a la solution... M'arange pas du tout le 192.168.1.1

Je me posais la même question pour la maj, du coup depuis hier j'ai rien touché.

Donc suffit de DL le lien de Gelat et de lancer la maj depuis OpenWRT lui même ?

Y pas de commande directe pour faire la maj ?

 

Avec le firmware Xiaomi apparemment on pouvait utiliser des fréquences WIFI différentes des FR et booster la puissance, peut-on faire pareil avec OpenWRT

 

Merci de vos réponses.

Modifié par smotx

Partager ce message


Lien à poster
Le 07/10/2018 à 18:46, moustik_2002 a dit :

Hello Gelat, j'ai moi même suivi le tuto et en ce qui concerne la maj "stable" il suffit de passer par le portail web avec le tar dont tu remis le lien, rien de plus est nécessaire, en tout cas de mon point de vue (j'ai fait la manip en milieu de semaine et il semble que les bug rencontrés sur la bande passante 2.4 Ghz ont été fix).

Hello ter tous !

j'ai appliqué la procédure de maj que j'avais décrite et ça a bien marché : mon routeur est désormais avec la version stable d'openwrt. Alors pour la précision, j'avais laissé coché la case pour garder les conf lors du flashage.

Perso, j'ai eu pendant une semaine un problème d'accès ssh et luci (access denied) mais cela fonctionne aujourd'hui sans intervention de ma part (m'étais-je trompé de mdp ??? ou juste le fait d'avoir gardé les conf alors que je changeaixs de version majeure ???).

Bref, suite à cette maj, une seule chose à refaire : la récupération des fichiers i18n pour luci.

Partager ce message


Lien à poster

bonjour je viens d'essayé de suivre le tuto mais je pense que mon routeur viens de se bricker

j'ai installé jusqu'a l'etape 5 apparament sans soucis mais la plus d'acces le voyant reste orange fixe 

a l'etape 4 pour me connecté avec putty l'adresse 192.168.1.1 ne fonctionné pas donc j'ai tout installé via 192.168.31.1 pour avoir acces

Brické?

Partager ce message


Lien à poster
Il y a 2 heures, hornet02 a dit :

bonjour je viens d'essayé de suivre le tuto mais je pense que mon routeur viens de se bricker

j'ai installé jusqu'a l'etape 5 apparament sans soucis mais la plus d'acces le voyant reste orange fixe 

a l'etape 4 pour me connecté avec putty l'adresse 192.168.1.1 ne fonctionné pas donc j'ai tout installé via 192.168.31.1 pour avoir acces

Brické?

Avant flash: l'adresse du routeur via le wifi est 192.168.31.1. Après avoir installé le firmware dev Xiaomi pour activer le SSH, il faut toujours utiliser cette adresse qui est d'usine. C'est seulement après avoir installer OpenWRT que l'adresse change. A ce moment la nouvelle adresse par défaut d'OpenWRT est 192.168.1.1. En cas de blocage, essayer de redemarrer le routeur par un reboot "sec". Couper le courant. Normalement la LED est bleu apres avoir flashé OpenWRT.

Partager ce message


Lien à poster
Il y a 4 heures, hornet02 a dit :

bonjour je viens d'essayé de suivre le tuto mais je pense que mon routeur viens de se bricker

j'ai installé jusqu'a l'etape 5 apparament sans soucis mais la plus d'acces le voyant reste orange fixe 

a l'etape 4 pour me connecté avec putty l'adresse 192.168.1.1 ne fonctionné pas donc j'ai tout installé via 192.168.31.1 pour avoir acces

Brické?

Bonjour,

si la led orange persiste, il serait bon de vérifier ce que dit la log via le port console.

Perso j'ai été bien emmerdé avec un pb de bad blocks sur la partition UBI, et je ne suis pas le seul...

Tu peux tester en flashant une version spéciale (avec une partition UBI un peu plus petite), si ça passe, c'est que c'était ça !

Par contre pour le débricker, il te faut absolument passer par le port console pour repasser sur le firm d'origine, une manip que tu trouvera dans ce topic.

Cdt

openwrt-ramips-mt7621-mir3g-squashfs-kernel1.bin

openwrt-ramips-mt7621-mir3g-squashfs-rootfs0.bin

Partager ce message


Lien à poster

par contre la carte n'est pas la meme que celle montrée un peu plus haut

il faut du 5v ou le 3.3v suffit?

pour le 5v il faut demonté la partie en alu?

 

IMG_20181025_185514.jpg

Modifié par hornet02

Partager ce message


Lien à poster

je comprend pas trop ta demarche pour debriker

je me connect a putty

j'appuis sur 4

apres je comprend pas les commandes?

j'ai mis sur clé usb les 3 fichiers

miwifi_ssh.bin

et les 2 autres que tu m'a filé

 

Partager ce message


Lien à poster

Extrait quand même les dernières lignes de la log boot pour savoir ce qui merde...

Sinon si tu avais lu la page précédente :

 

j'ai réussi a le débricker en faisant ceci :

1 - Conect to Serial
2 - type 4 to enter command prompt
3 - type this commands:
setenv flag_try_sys1_failed=0 (check if flag name is correct with printenv)
setenv flag_try_sys2_failed=0 (check if flag name is correct with printenv)
setenv flag_last_success=0
saveenv
4 - connect pendrive with original stock dev firmware renamed to miwifi.bin
5 - default brick recovery process: reboot pressing reset button until yellow led start flashing, then release reset button.
6 - wait completion
7 - Done.

Partager ce message


Lien à poster

salut j'ai lu cette page 

j'appuis sur 4

 copier /coller

setenv flag_try_sys1_failed=0 (check if flag name is correct with printenv)
setenv flag_try_sys2_failed=0 (check if flag name is correct with printenv)
setenv flag_last_success=0
saveenv

 

putty3.log

Partager ce message


Lien à poster

Oui, maintenant le routeur est près à être reflashé.

Mais ta log montre plutôt un pb avec ton image qui semble corrompue. Essaye une autre version, ce n'est pas un pb de bad blocks.

Partager ce message


Lien à poster

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×