Aller au contenu
Milhie

Carte réseau wifi non détectée sous Ubuntu 18.04

Messages recommandés

Bonsoir,
Débutante sur ubuntu, et n'ayant pas trouvé de solution sur google, je viens solliciter votre aide car ubuntu ne reconnait plus ma carte réseau wifi...

Mon pc : Dell inspiron 2in1 5491 i7 16go de ram et SSD 512Go.
Carte réseau : intel(R) Wireless-AC 9560

J'ai installé ubuntu 18.04 LTS en dual boot avec windows 10 (j'ai suivi le tuto dell pour l'installation, j'ai dû passer le ssd en ahci  avant l'installation d'ubuntu car il était configuré en raid)
Depuis 1 semaine que je possède ce PC et que j'utilise tous les jours, tout fonctionnait correctement: internet, son, bluetooth etc...
Depuis ce matin la carte wifi n'est plus reconnu dans ubuntu alors que sur windows le wifi fonctionne correctement.

Après avoir parcouru pas mal de forums, téléchargé les drivers intel pour ubuntu pour ma carte réseau comme indiqué sur cette page: https://www.intel.fr/content/www/fr/fr/ … rking.html

J'ai tenté une réinstallation d'ubuntu en préservant le /home puis une nouvelle en supprimant tout, le problème persiste à chaque fois.. Internet fonctionne lors de l'installation mais une fois installé la carte réseau n'apparait pas.
Si je boote sur ma clef usb le réseau wifi fonctionne.. J'utilise la même clef USB que celle utilisé pour la première installation..

J'ai vu qu'une autre personne avait ce problème également (lien vers le sujet: https://forum.ubuntu-fr.org/viewtopic.php?id=2048616), on lui a demandé d'effectuer quelques commandes, les voici pour mon cas :

 

lspci -k -nn | grep -A 3 -i net
00:14.3 Network controller [0280]: Intel Corporation Device [8086:02f0]
	Subsystem: Intel Corporation Device [8086:4234]
	Kernel driver in use: iwlwifi
	Kernel modules: iwlwifi
lsmod | grep cfg80211
cfg80211              704512  3 iwlmvm,iwlwifi,mac80211
milhie@milhie-Inspiron-5491-2n1:~$ rfkill list all
0: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
iwconfig
lo        no wireless extensions.
ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
uname -r -m
5.3.0-40-generic x86_64
nmcli dev wifi

n'affiche rien du tout

 

D'avance merci pour votre précieuse aide...

Modifié par Mreve
Mise en page du message :)

Partager ce message


Lien à poster

Bonjour @Milhie je vais interpeller nos linuxiens ,enfin ceux qui ont une certaine expérience et qui me viennent à l'esprit : les autres peuvent répondre évidemment si ils pensent connaitre la réponse ,  @Le Crabe , @Mreve entre autres 

Partager ce message


Lien à poster

Merci! :)

Si ça peux aider pour trouver d'où vient le problème :

Quand je démarre mon pc, dans le choix des boots, si je vais dans les options Ubuntu j'ai 2 versions proposées,  Ubuntu 5.3.0-40-generic et Ubuntu 5.3.0-28-generic si je choisis la deuxième le wifi fonctionne correctement alors qu'avec la .40 (celle qui est chargée par défaut) la carte n'apparaît pas.. 

5.3.0-40-generic
5. et une en .28. se boote sur la .28 le wifi foncSur la .40 (celle qui est chargée par défaut) la carte n'est pas détectée... 

 

Partager ce message


Lien à poster

Bonjour @Milhie et bienvenue sur le forum ! :c_happy:

La réponse est simple, c'est un bug du noyau ! Le bug a été remonté.

EDIT : Pour être exact, le noyau 5.3.0-40 casse la compatibilité avec pas mal de drivers wifi.

Tant que cela n'a pas été corrigé, reste sur ton Ubuntu 5.3.0-28. Surveille tes mises à jour du noyau, la prochaine réglera sûrement le problème. :wink:

Modifié par Mreve

Partager ce message


Lien à poster

Merci! :)

Je viendrai poster des nouvelles si le bug est réparé avec les prochaines mises à jour.. 

5.3.0-40-generi
Modifié par Mreve
  • J'aime 1

Partager ce message


Lien à poster

Rejoindre la conversation

Vous pouvez publier maintenant et vous inscrire plus tard. Si vous avez un compte, connectez-vous maintenant pour publier avec votre compte.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


×
×
  • Créer...