Aller au contenu
thierry34

erreur mise à jour logicielle oppo find X

Messages recommandés

hello!! j'essaye la conversion ozip / zip.

j'ai installé python à l'endroit par defaut. Dans ce dossier d'install, j'ai mis le dossier (dézippé) "oppo_ozip_decrypt-master".

quand je lance python, j'ai bien la fenetre dos qui s'ouvre avec en haut le nom de python3. Par contre si je fais comme tu me dis, c'est a dire ouvrir une fenetre dos dans le dossier "oppo_ozip_decrypt-master" ,c'est la commande windows et il ne reconnait pas la cde pip3.

si j'ouvre la fenetre dans le dossier python, j'ai bien la fenetre dos avec python en haut comme qd je le lance. mais si j'ecris la ligne "pip3...." : ça me fait ça :

>>> pip3 install -r requirements.txt
  File "<stdin>", line 1
    pip3 install -r requirements.txt
         ^
SyntaxError: invalid syntax

si j'ouvre python et que je navigue jusqu'au depot j'ai ça :

>>> C:\Users\thierry\AppData\Local\Programs\Python\Python38\oppo_ozip_decrypt-ma
ster
  File "<stdin>", line 1
    C:\Users\thierry\AppData\Local\Programs\Python\Python38\oppo_ozip_decrypt-ma
ster

   ^
SyntaxError: unexpected character after line continuation character
>>>

je merde quelque chose ....

Partager ce message


Lien à poster

Salut,

Désolé, la commande pour Windows c'est pip pas pip3.

(Pas le temps de t'aider plus ce soir si tu as d'autres problème , déso)

PS : Sinon, tu as flashé le ZIP ? EDIT : J'avais pas vu ton MP.

Modifié par Mreve

Partager ce message


Lien à poster

Note : Message récapitulatif pour pour d'éventuels futurs lecteurs de ce topic, la suite des évènements s'étant déroulé en MP.

Le firmware modifié a pu être flashé avec succès, ColorOS 6 s'est correctement installé et la recovery TWRP a été remplacé par la stock recovery.

==> Le root a été perdu au passage (ce qui est normal).

-------------------------------

Pour rooter sans installer TWRP, il y a plusieurs méthodes. La plus simple étant de booter sur TWRP sans l'installer :

1) Récupérer la version de TWRP compatible avec le téléphone (ici non officielle).

2) Récupérer la dernière version de Magisk.

3) Redémarrer le téléphone en mode fastboot.

4) Booter sur TWRP ( booter != flasher) :

fastboot boot twrp-9.0-recovery-findx-20190506.img

6) Depuis TWRP flasher le zip Magisk puis redémarrer normalement.

Modifié par Mreve

Partager ce message


Lien à poster
Il y a 2 heures, Mreve a dit :

Note : Message récapitulatif pour pour d'éventuels futurs lecteurs de ce topic, la suite des évènements s'étant déroulé en MP.

Le firmware modifié a pu être flashé avec succès, ColorOS 6 s'est correctement installé et la recovery TWRP a été remplacé par la stock recovery.

==> Le root a été perdu au passage (ce qui est normal).

-------------------------------

Pour rooter sans installer TWRP, il y a plusieurs méthodes. La plus simple étant de booter sur TWRP sans l'installer :

1) Récupérer la version de TWRP compatible avec le téléphone (ici non officielle).

2) Récupérer la dernière version de Magisk.

3) Redémarrer le téléphone en mode fastboot.

4) Booter sur TWRP ( booter != flasher) :


fastboot boot twrp-9.0-recovery-findx-20190506.img

6) Depuis TWRP flasher le zip Magisk puis redémarrer normalement.

Alors, la suite !!! je suis sur mon tel mode fastboot. j'ai ouvert cmd à partir du dossier ou il y a adb.exe et ou j'ai mis le fichier du twrp que j'ai téléchargé à partir de ton lien (merci d'ailleurs, je sais pas comment tu fais pour trouver !!! j'ai cherché pendant longtemps et je ne l'ai pas trouvé !! trop fort !!).

j'ai connecté le tel, bien sur, et inscrit la commande ci dessus, voila la réponse que j'ai : (ça marche jamais du premier coup avec moi !!!

G:\oppo find x\platform-tools>fastboot boot twrp-9.0-recovery-findx-20190506.img

Sending 'boot.img' (65536 KB)                      OKAY [  2.088s]
Booting                                            FAILED (remote: 'unknown comm
and')
fastboot: error: Command failed

je fais quoi de pas bien ?????

Partager ce message


Lien à poster
Le 19/02/2020 à 16:59, Mreve a dit :

Salut,

Désolé, la commande pour Windows c'est pip pas pip3.

(Pas le temps de t'aider plus ce soir si tu as d'autres problème , déso)

PS : Sinon, tu as flashé le ZIP ? EDIT : J'avais pas vu ton MP.

pour bien etre d'accord ,j'ai mis le dossier (oppo ozip ....) dans le dossier de l'install de python. ok ?

j'ouvre python ,j'ai la fenetre dos qui s'ouvre avec a gauche l'entete python, je vais ds le dossier (oppo ozip...) il  faut que je marque le chemin du dossier ds python ? si oui j'ai ce message

Python 3.8.1 (tags/v3.8.1:1b293b6, Dec 18 2019, 23:11:46) [MSC v.1916 64 bit (AMD64)] on win32
Type "help", "copyright", "credits" or "license" for more information.
>>> C:\Users\thierry\AppData\Local\Programs\Python\Python38\oppo_ozip_decrypt-master
  File "<stdin>", line 1
    C:\Users\thierry\AppData\Local\Programs\Python\Python38\oppo_ozip_decrypt-master   ^
SyntaxError: unexpected character after line continuation character >>>

si j'ouvre directement (comme tu dis avec maj et clic droit), c'est une fenetre dos qui s'ouvre avec le logo normal (en haut a gauche). et la cde pip n'est pas reconnu..

et si je tape la commande ds python ouvert a partir du dossier python

Python 3.8.1 (tags/v3.8.1:1b293b6, Dec 18 2019, 23:11:46) [MSC v.1916 64 bit (AMD64)] on win32
Type "help", "copyright", "credits" or "license" for more information.
>>> pip install -r requirements.txt
  File "<stdin>", line 1
    pip install -r requirements.txt        ^
SyntaxError: invalid syntax >>>

voila voila :)

Partager ce message


Lien à poster

L'aventure continue ! :tongue:

Il y a 18 heures, thierry34 a dit :

j'ai ouvert cmd à partir du dossier ou il y a adb.exe et ou j'ai mis le fichier du twrp que j'ai téléchargé

Bon normalement il n'y a pas de raison que tu te sois trompé mais tu es bien dans ce dossier plateform-tools ? De ce que je comprends tu ne l'as pas fait mais je précise, il ne faut pas cliquer sur le adb.exe car là on utilise le fastboot !

Soit tu cliques sur fastboot.exe, soit tu ouvres cmd dans ce dossier.
 

Il y a 18 heures, thierry34 a dit :

Sending 'boot.img' (65536 KB)  OKAY [  2.088s]
Booting                          FAILED (remote: 'unknown command')
fastboot: error: Command failed

Tu avais déjà flashé TWRP via le fastboot avant non ? J'imagine donc que le USB debugging et le OEM unlock sont déjà activés.

Au vu du résultat de la commande, ton téléphone est correctement détecté en mode fastboot (la commande fastboot devices devrait renvoyer quelque chose)

Le 'unknown command' me laisse à penser que la commande fastboot boot n'est pas reconnu sur les téléphones Oppo ce qui est étrange au vu de ce que j'ai pu lire.

Je viens de trouver le Device Tree de TWRP pour le Find X ! C'est génial ! Ça veut dire que si un jour je m'ennuie, je peux potentiellement essayer de patcher TWRP pour éviter d'avoir à enlever le compatibility.zip des firmwares avant de les flasher. Ça me ferait un bon exercice vu que je ne sais pas faire ! :biggrin:

Bref, sur Github, le gars précise qu'on peut booter sur TWRP via la commande fastboot boot recovery.img.

Essayons donc de voir ce qui coince :

Déjà, utilise le dossier plateform-tools que je t'ai envoyé (source directe de Google). Enregistre le sur ton bureau. Vérifie qu'il n'y ait pas d'espaces dans le chemin absolu :

Il y a 18 heures, thierry34 a dit :

G:\oppo find x\platform-tools\

Ça par exemple c'est pas top ! J'ai déjà eu des problèmes à cause de ça. Mets le sur ton bureau par exemple : C:\Users\thierry\Bureau\platform-tools\

Ça ne va pas régler le problème mais c'est une bonne pratique à avoir.


Une fois CMD ouvert dans ce dossier (et USB Debugging + OEM unlock activé)

Donne moi dans le doute le résultat de ces 2 commandes :

fastboot devices
fastboot boot

 

Modifié par Mreve

Partager ce message


Lien à poster
Il y a 19 heures, thierry34 a dit :

pour bien etre d'accord ,j'ai mis le dossier (oppo ozip ....) dans le dossier de l'install de python. ok ?

Ahah ! Nan ! :biggrin:

J'aurais dû te parler des variables d'environnement. Tu vas voir, tout va s'éclairer !

Les variables d'environnement

Comme tu l'as sûrement déjà remarqué, il faut parfois ouvrir le terminal (= invité de commande = cmd) dans un dossier particulier pour pouvoir profiter de commandes spécifiques. Certaines commandes, au contraire, sont reconnues par l'OS depuis n'importe où. La raison est simple

Lorsque que tu tapes une commande, tu exécutes un programme en fait. l'OS essaie alors d'exécuter le programme demandé (fastboot.exe par exemple pour Windows). Il cherche dans le dossier de travail (celui dans lequel tu te trouves) et dans des dossiers du système (C:\Windows\system32 par exemple pour Windows).

C'est la variable d'environnement <PATH> qui contient la liste des répertoires dans lesquels vont être recherchés les fichiers exécutables. On retrouve cette variable sous Windows (%PATH%) et sous Unix et Linux ($PATH).

Il est évidemment tout à fait possible de modifier cette variable pour accéder à une commande depuis n'importe quel endroit du PC.
==> Exemple pour adb/fastboot.


Dans ton cas, normalement Python s'ajoute automatique au PATH pendant l'installation afin de pouvoir être lancé depuis n'importe où. En tout cas la commande py au lieu de python devrait être reconnu.
 

Ouvre un invité de commande.

Notes : là par exemple je suis dans C:\Users\thierry. J'aurais très bien pu me mettre directement dans le dossier oppo_ozip_decrypt-master, ça m'aurait évité d'avoir à donner le chemin de requirement.txt.

C:\Users\thierry\> py

Tu devrais normalement entrer dans l'environnement python. Regarde si tu peux importer pip

>>> import pip

Si tu n'as pas d'erreur ça veut dire que tu devrais pouvoir utiliser pip. 

Tu peux très bien installer de suite les dépendances pendant que tu es dans l'environnement python via :

>>> pip install -r \chemin\vers\requirement.txt

EDIT : Je raconte n'importe quoi. Il ne faut pas le faire depuis l’interpréteur Python.

Mais aussi en dehors car python est dans la variable PATH :

C:\Users\thierry\> py -m pip install -r \chemin\vers\requirement.txt


Si pip est aussi dans le PATH (normalement oui), tu peux faire :

C:\Users\thierry\> pip install -r \chemin\vers\requirement.txt


J'espère que tu comprends bien que le fait d'ouvrir le dossier oppo_ozip_decrypt-master (que tu peux laisser sur ton bureau) te permet simplement de ne pas à avoir à donner le chemin du fichier requirement.txt.

Note : Cette histoire de variable PATH ne fonctionne que pour les exécutables, pas les fichiers normaux. Ne t'embrouille pas. :wink:

C:\...\oppo_ozip_decriypt_master> py -m pip install -r requirement.txt


Remarque qu'il est aussi possible d'installer directement les dépendances sans passer par ce fichier. Si tu regardes dedans tu vois qu'il y seulement pycryptodome et docopt.

Il est donc aussi possible de faire directement :

C:\Users\thierry\> pip install pycryptodome docopt

 

Modifié par Mreve
EDIT

Partager ce message


Lien à poster

t'es au top !!!! tu bosses la dedans je presume ????

alors , c'est que je lance adb.exe d'ou l'erreur surement.

j'ai fait comme m'a dit mon prof, j'ai mis le dossier téléchargé "platform" sur le bureau et j'ai connecté le tel en mode fastboot, usb debugging on , et j'ai fait les 2 commandes :

la première ; fastboot devices : le tél est identifié (une série de chiffre suivi de fastboot.

fastboot boot : réponse : fastboot : usage : expected argument

Partager ce message


Lien à poster
il y a 37 minutes, thierry34 a dit :

t'es au top !!!! tu bosses la dedans je presume ????

Ça dépend ce que tu appelles là dedans. Tout ce qui est bidouille Android j'ai appris ça tout seul. Après oui, je suis étudiant en école d'ingénieur filière Informatique, Réseau et Cybersécurité donc ça aide un peu. :smile:

il y a 37 minutes, thierry34 a dit :

alors , c'est que je lance adb.exe d'ou l'erreur surement.

Ah ! Voilà pourquoi alors !

Si tu ne passes pas par adb.exe la commande devrait fonctionner alors :

fastboot boot twrp-9.0-recovery-findx-20190506.img

 

il y a 37 minutes, thierry34 a dit :

fastboot boot : réponse : fastboot : usage : expected argument

Donc fastboot boot est reconnu. Le usage : expected argument est normal puisqu'il faut un argument à la commande (twrp.img par exemple). Je voulais juste m'assurer que le bootloader de ton téléphone reconnaissait cette commande.

Modifié par Mreve

Partager ce message


Lien à poster

j'ai mis le dossier ozip sur le bureau. j'ai ouvert une invite a partir du bureau, j'ai fait "py" ,ça m'a marqué les trucs de python, j'ai fait import pip ,c'est passé a la ligne du dessous sans erreur.

Par contre quand je fais pip install, j'ai toujours l'erreur de syntaxe. 

>>> pip install -r \C:\Users\thierry\Desktop\oppo_ozip_decrypt-master\requirements.txt
  File "<stdin>", line 1
    pip install -r \C:\Users\thierry\Desktop\oppo_ozip_decrypt-master\requirements.txt
        ^
SyntaxError: invalid syntax

le tiret avant le r ,c'est bien le tiret du 6 ?

Modifié par Mreve
Suppression de l'énorme citation.

Partager ce message


Lien à poster
il y a 12 minutes, thierry34 a dit :

Par contre quand je fais pip install, j'ai toujours l'erreur de syntaxe. 

Pfff c'est moi qui suis con... :drhouse:

pip ne peut pas se lancer depuis l’interpréteur python. Il faut le lancer depuis cmd puisqu'il installe des modules pour python.

C:\...\> pip install -r \C:\Users\thierry\Desktop\oppo_ozip_decrypt-master\requirements.txt

Modifié par Mreve
orthographe

Partager ce message


Lien à poster
il y a 18 minutes, Mreve a dit :

Ça dépend ce que tu appelles là dedans. Tout ce qui est bidouille Android j'ai appris ça tout seul. Après oui, je suis étudiant en école d'ingénieur filière Informatique, réseau et cybersécurité donc ça aide un peu. :smile:

Ah ! Voilà pourquoi alors !

Si tu ne passes pas par adb.exe la commande devrait fonctionner alors :


fastboot boot twrp-9.0-recovery-findx-20190506.img

 

Donc fastboot boot est reconnu. Le usage : expected argument est normal puisqu'il faut un argument à la commande (twrp.img par exemple). Je voulais juste m'assurer que le bootloader de ton téléphone reconnaissait cette commande.

j'ai toujours l'erreur ,pourtant il reconnait bien le tel

sending 'boot.img'    ok(2.085s)

booting                       failed(remote : unknown command

fastboot : error : command failed

 

 

Partager ce message


Lien à poster
il y a 18 minutes, Mreve a dit :

Pfff c'est moi qui suis con... :drhouse:

pip ne peut pas se lancer depuis l’interpréteur python. Il faut le lancer depuis cmd puisqu'il installe des modules pour python.

C:\...\> pip install -r \C:\Users\thierry\Desktop\oppo_ozip_decrypt-master\requirements.txt

désolé lol mais si j'ouvre une invite a partir du bureau (cmd), et que je tape la commande ,ça me marque que pip n'est pas reconnu comme une commande  interne ou externe ....

on devrait faire d'abord le tel , apres on verra ce probleme non ? :) :) :) 

mdr ,tu dois me maudir !!!!!

ça m'étonne pas que tu sois ingénieur dans ce domaine !!  moi j'ai voulu regarder des videos sur comment apprendre a utiliser python,ça a l'air interressant, mais si j'avais été plus jeune,je m'y serais interresse davantage lol !!! mais la , ça m'a gonflé mdr !!!

une petite précision, j'ai remarqué que qd ça me marque syntax erreur,j'ai une petite fleche sous le "i" de install .

hier, en bidouillant,j'ai ouvert le shell de python et j'ai fait les manips ds le shell.j'avais aussi l'erreur de syntaxe et ça me mettait le "i" de install ds un petit carré rouge. l'erreur de viendrait pas de la ?

 

Modifié par thierry34
  • Ahah 1

Partager ce message


Lien à poster
il y a 2 minutes, thierry34 a dit :

on devrait faire d'abord le tel , apres on verra ce probleme non ? :) :) :) 

Oui si tu veux. :smile:

 

il y a 17 minutes, thierry34 a dit :

j'ai toujours l'erreur ,pourtant il reconnait bien le tel

Se pourrait-il qu'il faille nécessairement flasher la recovery ? :mellow:

Que donne cette commande ?

fastboot boot twrp-9.0-recovery-findx-20190506.img

Si elle fonctionne et que ensuite tu reboot normalement, TWRP sera écrasée par la stock recovery.
Si tu reboot en recovery alors TWRP sera installé epour de bon mais ce n'est pas ce que l'on veut.

Partager ce message


Lien à poster
il y a 3 minutes, Mreve a dit :

 

Que donne cette commande ?


fastboot boot twrp-9.0-recovery-findx-20190506.img

 

sending se passe bien  (2.091s)

booting se passe mal !! failed (remote: unknown command)

 

Partager ce message


Lien à poster
il y a 27 minutes, thierry34 a dit :

booting se passe mal !! failed (remote: unknown command)

Oups ! J'ai oublié de modifier la commande après le copier-coller. Je voulais dire :

fastboot flash recovery twrp-9.0-recovery-findx-20190506.img

Sinon c'est la même commande qu'avant donc bon... :rolleyes:

EDIT : @thierry34 J'ai failli refaire la même erreur. J'ai édité quelque secondes après. Tu as bien vu la version éditée ?

Modifié par Mreve
EDIT 2 : Oubli de 'recovery' dans la commande

Partager ce message


Lien à poster
il y a une heure, thierry34 a dit :

fastboot boot : réponse : fastboot : usage : expected argument

En fait je viens de me rendre compte que cette réponse n'assure pas du tout que le bootloader du téléphone accepte la commande fastboot boot.

Il s'agit d'une réponse du PC, pas du téléphone (remote).

  • Perplexe 1

Partager ce message


Lien à poster

Et ben heureusement que c'est le weekend ! J'ai encore oublié un mot dans la commande ! :c_coldsweat:

fastboot flash recovery twrp-9.0-recovery-findx-20190506.img
  • Ahah 1

Partager ce message


Lien à poster

@thierry34

il y a 7 minutes, Mreve a dit :

En fait je viens de me rendre compte que cette réponse n'assure pas du tout que le bootloader du téléphone accepte la commande fastboot boot.

Il s'agit d'une réponse du PC, pas du téléphone (remote).

Je voulais simplement revenir sur ce que j'ai dit quand je pensais que la commande fastboot boot était reconnu par ton téléphone.

  • J'aime 1

Partager ce message


Lien à poster

cool , ça a installé TWRP sur le tél. je suis dessus .

je flashe magisk ?

Modifié par thierry34

Partager ce message


Lien à poster
il y a 1 minute, thierry34 a dit :

cool , ça a installé TWRP sur le tél. je suis dessus .

Ah mais du coup tu préfères installer TWRP ? Tu ne pourras plus faire d'OTA alors.

Je voulais juste voir si fastboot flash recovery fonctionnait !

Aurais-je mal compris ?

Partager ce message


Lien à poster
il y a 1 minute, Mreve a dit :

Ah mais du coup tu préfères installer TWRP ? Tu ne pourras plus faire d'OTA alors.

Je voulais juste voir si fastboot flash recovery fonctionnait !

Aurais-je mal compris ?

ah non !! vu quil va y avoir des mises a jour pour color os7,  donc ça fonctionne mais j'aurais pas du l'installer alors ?

Partager ce message


Lien à poster
il y a 1 minute, thierry34 a dit :

donc ça fonctionne mais j'aurais pas du l'installer alors ?

Concrètement qu'est ce que tu as fait ? Tu as fait fastboot flash recovery ... et ensuite ?

Partager ce message


Lien à poster

ben une fois que j'ai validé , sur cmd ,ça s'est bien passé ,du coup, je suis allé voir sur le téléphone si twrp était installé en faisant "recovery mode" et "power". du coup j'ai twrp d'installer sur le tel. Je crois que j'ai fait une boulette ,c'est ça ? 

Partager ce message


Lien à poster

Rejoindre la conversation

Vous pouvez publier maintenant et vous inscrire plus tard. Si vous avez un compte, connectez-vous maintenant pour publier avec votre compte.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


×
×
  • Créer...